Bug 36778 - hang after pcmcia-cs loaded and reboot
hang after pcmcia-cs loaded and reboot
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-20 07:10 EDT by Michal Roszkowski
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:11:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Roszkowski 2001-04-20 07:10:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75C-CERN UNIX asis-w8 45 [en] (X11; U; Linux
2.2.17-14.0 i686)


the machine boots fine on power on, but always hangs on reboot...
if pcmcia-cs is not loaded on initial boot, then reboot is fine.

this problem still happens even if no pcmcia cards are inserted.

Reproducible: Always
Steps to Reproduce:
1.power on machine and wait for boot
2.log in and type reboot
3.during next boot machine will hang
	

Actual Results:  After a reboot, my Thinkpad 570 hangs at:
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 236k freed.

computer is an IBM ThinkPad 570
lspci:
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev
03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:06.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:06.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:06.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:06.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:07.0 Communication controller: Lucent Microelectronics WinModem 56k (rev
01)
01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV]
(rev 20)
09:00.0 Ethernet controller: 3Com Corporation 3CCFE575BT Cyclone CardBus
(rev 01)
Comment 1 Arjan van de Ven 2001-04-20 07:24:45 EDT
Just to get the picture clear: does it hang before the machine reboots, 
or does it hang during the bootup from a "soft" reboot ?
Comment 2 Michal Roszkowski 2001-04-20 08:40:36 EDT
to clarify,
once the reboot command is given, all services are stopped nicely, and the
machine reboots...
the kernel is found, uncompressed and everything is fine until "freeing unused
kernel memory..."

so the hang is after the reboot...
the machine can be switched off at this stage, but if ctl-alt-del is pressed,
then i get a hard hang so that the even the off button does not work (i have to
remove the battery).
Comment 3 Arjan van de Ven 2001-04-20 09:24:28 EDT
Could you try with appending "reboot=c" to the lilo prompt to change the way
Linux does a reboot ?
Comment 4 Michal Roszkowski 2001-04-20 10:02:50 EDT
still no good...
i booted normally on power-on, did a reboot, at the lilo boot prompt typed:
linux reboot=c

the only difference is that this time after "Freeing unused kernel memory: 236k
freed", i got an oops

Freeing unused kernel memory: 236k freed
Unable to handle kernel paging request at virtual address 00f0838b
printing eip:
c0113da3
pgd entry c116a00c: 0000000000000000
pmd entry c116a00c: 0000000000000000
.. pmd not present!
Oops: 0000
CPU: 0
EIP: 0010:[<c0113da3>]
EFLAGS: 00010007
eax: c110ddf4 ebx: 00f0838b ecx: 00000001 edx: c110ddf8
esi: c110ddcc edi: 00f08383 ebp: c026fedc esp: c026fec0

etc, etc...
kernel panic...
Comment 5 Arjan van de Ven 2001-04-20 10:06:48 EDT
I'm sorry I should have been more clear. The "reboot=c" was intended for the
_initial_ boot so the "reboot" command would be affected by it.

Comment 6 Michal Roszkowski 2001-04-23 04:35:12 EDT
oh, sorry :)
still no good... hangs as previously described...

Note You need to log in before you can comment on or make changes to this bug.