Bug 367801 - Unable to Import Camera Photos Using gThumb
Unable to Import Camera Photos Using gThumb
Status: CLOSED DUPLICATE of bug 389091
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-05 20:48 EST by Chris Spencer
Modified: 2008-01-05 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 17:09:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Spencer 2007-11-05 20:48:58 EST
Description of problem:
An "Import Photos" gThumb dialog automatically starts whenever a digital camera
is connected. This usually downloads photos perfectly, but after a recent kernel
upgrade (I'm currently using 2.6.23.1-10.fc7 #1 SMP), the dialog fails complaining:

"An error occurred in the io-library ('Could not claim the USB device'): Could
not claim interface 0 (Operation not permitted). Make sure no other program or
kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have
read/write access to the device."
Comment 1 Gustavo Maciel Dias Vieira 2007-11-24 07:50:36 EST
This bug is probably a duplicate of #389091
Comment 2 Chris Spencer 2007-11-24 12:45:03 EST
Well, since this bug report is older, #389091 would be a duplicate of this one.
But yes, the problem appears identical. The camera I'm using is a Canon
Powershot SD1000. Canon seems to be the recurring theme.
Comment 3 Norman Smith 2007-11-28 17:53:08 EST
I have the same problem with a Kodak CX7220.  My wife could import photos in the
past but today it fails.  I played around with gthumb and changed the permission
with chmod +s.  This got past the error but I could not download from the
camera.  The new directory for the photos was created belonging to root not her
user as you would expect but it said it could not write to the directory.  At
that point I put the permissions back to normal and looked for open bugs. 
(2.6.23.1-21.fc7)
Comment 4 Chris Spencer 2008-01-03 14:59:16 EST
I can import photos as root. Googling found many others with potential solutions
to this problem, such as:

http://www.hyperborea.org/journal/archives/2007/11/14/digikam-permissions/
http://www.fedoraforum.org/forum/showthread.php?t=170607&page=2&pp=15&highlight=camera

which recommend running the command:

/usr/lib/libgphoto2/print-camera-list udev-rules-0.98 group users mode 0660 >
/etc/udev/rules.d/90-libgphoto2.rules

However, all this does is give me a different error:

An error occurred in the io-library ('Bad parameters'): Could not find USB
device (vendor 0x4a9, product 0x3119). Make sure this device is connected to the
computer.
Comment 5 Jon Stanley 2008-01-05 17:09:06 EST

*** This bug has been marked as a duplicate of 389091 ***

Note You need to log in before you can comment on or make changes to this bug.