Bug 368101 - Doesn't show Amazon e-mail
Doesn't show Amazon e-mail
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 06:06 EST by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 09:23:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
amazon-email.txt (16.42 KB, text/plain)
2007-11-06 06:06 EST, Bastien Nocera
no flags Details
Screenshot-INBOX.png (13.13 KB, image/png)
2007-11-06 06:07 EST, Bastien Nocera
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 494170 None None None Never

  None (edit)
Description Bastien Nocera 2007-11-06 06:06:53 EST
evolution-2.12.1-3.fc8
gtkhtml3-3.16.1-1.fc8

Evolution doesn't show any text or images when loading this e-mail from Amazon.
Comment 1 Bastien Nocera 2007-11-06 06:06:53 EST
Created attachment 248941 [details]
amazon-email.txt
Comment 2 Bastien Nocera 2007-11-06 06:07:52 EST
Created attachment 248951 [details]
Screenshot-INBOX.png

What shows up in Evo
Comment 3 Matthew Barnes 2007-11-06 07:42:16 EST
I see that too.  Looks like Evolution (or GtkHTML) is having trouble with the
text/html part of the message.  If you switch to "Prefer Plain" you can at least
read the text/plain part.

  Edit -> Preferences -> Mail Preferences -> HTML Messages -> HTML Mode
Comment 4 Milan Crha 2007-11-06 09:23:00 EST
I never saw such an ugly formatted HTML page, never ever. Maybe I didn't see
enough yet. They should try to validate it with W3C validator, because the <BR>
is not a pair element, as far as I know... 
Nevertheless, moving upstream [1] and attaching patch for gtkhtml there.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=494170

Note You need to log in before you can comment on or make changes to this bug.