Bug 36817 - 3CCFE575BT cannot resume
3CCFE575BT cannot resume
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-20 08:55 EDT by Michal Roszkowski
Modified: 2015-01-04 17:01 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:13:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Roszkowski 2001-04-20 08:55:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75C-CERN UNIX asis-w8 45 [en] (X11; U; Linux
2.2.17-14.0 i686)


3Com 3CCFE575BT cardbus network card works fine until a suspend/resume...
card is 100megabit capable, but running at 10megabits...

the card seems to suspend fine, but when it resumes, the 100Mbit led is on
instead of the 10Mbit led, and the card obviously does not function.

Reproducible: Always
Steps to Reproduce:
1.boot system
2.suspend system
3.resume system
	

Actual Results:  problem can also be reproduced with:
cardctl suspend
cardctl resume

but it can be fixed with:
cardctl eject
cardctl insert

(physical eject/insert works fine as well)

above all worked fine with RH 6.2
machine is an IBM ThinkPad 570

lspci:
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev
03)
00:02.0 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:02.1 CardBus bridge: Texas Instruments PCI1450 (rev 03)
00:05.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:06.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:06.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:06.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:06.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:07.0 Communication controller: Lucent Microelectronics WinModem 56k (rev
01)
01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV]
(rev 20)
09:00.0 Ethernet controller: 3Com Corporation 3CCFE575BT Cyclone CardBus
(rev 01)
Comment 1 apeacock 2001-04-24 10:39:19 EDT
I'm finding similar behavior with the 3Com PCI 3CCFE575CT Tornado CardBus on a
Dell Inspiron 7500.  The card works fine until a suspend, at both 10 and 100
mb.  I have configured pcmcia to restart in apmd, but this seems to mostly fail
-- pcmcia-core cannot be removed because yento-socket is using it, and for some
reason the pcmcia init script won't try to rmmod yento-socket.  If I manually
remove the modules, I can at least restart pcmcia successfully, but restarting
networking doesn't seem to work very reliably.

I believe this is a kernel 2.4 problem.  I noticed the same behavior in RH 7.0
after trying a 2.4 kernel (I went back to 2.2 to fix it), but maybe its just a
kernel config problem?
Comment 2 apeacock 2001-05-02 10:43:20 EDT
Some more info on the Dell Inspiron 7500 with 3Com PCI 3CCFE575CT Tornado
CardBus:  ejecting/reinserting the card does not solve the problem for me
(neither physically nor with cardctl).  In order to get networking back up, a
reboot is neccesary.  Restarting networking, or even issuing a 'pump $PUMPARGS'
command manually, results in sporadic, temporary lock-ups, as if the system is
in a tight cli()/sti() loop.  Interrupts seem to get disabled every 10-30
seconds, then are reenabled 5-10 seconds later.  This continues until pump is
terminated.

Note You need to log in before you can comment on or make changes to this bug.