Bug 36846 - perl-Getopt-Long from DMA conflicts with perl from disc1
perl-Getopt-Long from DMA conflicts with perl from disc1
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
7.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-20 11:44 EDT by Ed Marshall
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-03 10:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Marshall 2001-04-20 11:44:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-2 i686; en-US; 0.8) Gecko/20010217


Installing perl-Getopt-Long-2.24-10 from the developer module archive
results in a conflict between the Getopt::Long support built into perl 5.6.0.

Reproducible: Always
Steps to Reproduce:
# rpm -Uvh disc1/RedHat/RPMS/perl-5.6.0-12.<arch>.rpm
# rpm -Uvh DMA/CPAN/RPMS/perl-Getopt-Long-2.24-10.<arch>.rpm

Actual Results:  Every file in perl-Getopt-Long conflicts with existing
files from perl-5.6.0-12.

Expected Results:  Could be a few ways to cleanly solve this:

- install Getopt::Long in site_perl; I'm not sure what would happen
  if /usr/lib/perl5/5.6.0 and /usr/lib/perl5/site_perl/5.6.0 both
  contain the same modules; I'd expect the main distribution to win,
  but I haven't tested it.

- split the core modules that ship with perl into sub-packages when
  possible (ie. in this case, split perl-Getopt-Long off into another
  package). This could actually result in a lot more flexibility, but
  it'll introduce a whole new series of dependancies that noone is
  currently looking for; probably not a good idea until 8.0. ;-)

Easy workaround; just --force it into place. Not so cool at upgrade time,
though.
Comment 1 Chip Turner 2003-04-11 17:01:43 EDT
this should now be possible in the latest RH releases.
Comment 2 Ed Marshall 2003-07-03 10:49:06 EDT
Since the Developer Module Archive no longer exists, this doesn't really matter
all that much anymore. ;-)

Note You need to log in before you can comment on or make changes to this bug.