Bug 368461 - setfacl has wrong exit code
setfacl has wrong exit code
Status: CLOSED DUPLICATE of bug 368451
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: acl (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jiri Moskovcak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 11:18 EST by Jiri Moskovcak
Modified: 2015-02-01 17:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 07:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2007-11-06 11:18:14 EST
Description of problem:
setfacl returns 0 even if it fails.

Version-Release number of selected component (if applicable):
acl-2.2.39-2.1.el5

How reproducible:
100%

Steps to Reproduce:
# setfacl --restore=acl.dump
setfacl: acl.dump: Invalid argument in line 2
# echo $?
0

acl.dump contains some wrong informations.
  
Actual results:
setfacl returns zero exit code => succes.

Expected results:
setfacl should return non-zero exit code.
Comment 1 Jiri Moskovcak 2007-11-07 07:10:04 EST

*** This bug has been marked as a duplicate of 368451 ***

Note You need to log in before you can comment on or make changes to this bug.