Bug 368541 - sys/io.h missing from glibc-headers
sys/io.h missing from glibc-headers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 368401
  Show dependency treegraph
 
Reported: 2007-11-06 12:07 EST by Phil Knirsch
Modified: 2016-11-24 07:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 12:15:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Knirsch 2007-11-06 12:07:28 EST
Description of problem:

While compiling a package that needs iopl i got this error message on ppc64:

 gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector
--param=ssp-buffer-size=4 -m64 -mminimal-toc -o .libs/bmc-watchdog 
bmc_watchdog-bmc-watchdog.o  ../../libfreeipmi/src/.libs/libfreeipmi.so -lgcrypt
-lm 
../../libfreeipmi/src/.libs/libfreeipmi.so: undefined reference to `inb'
../../libfreeipmi/src/.libs/libfreeipmi.so: undefined reference to `outb'
../../libfreeipmi/src/.libs/libfreeipmi.so: undefined reference to `iopl'

After looking into it it turns out that ppc64 doesn't come with a sys/io.h
header file.

Version-Release number of selected component (if applicable):

glibc-2.7-2

How reproducible:

Always

Steps to Reproduce:
1. Try compile an application that uses iopl on ppc64
2. Watch it fail
3.
  
Actual results:

See above.

Expected results:

Program should compile resp. sys/io.h should be present on ppc64.

Additional info:

I'm not sure if iopl and friends are available at all on ppc64, so this might
actually be NOTABUG and just not possible on ppc64.
Comment 1 Ulrich Drepper 2007-11-06 12:15:35 EST
It is NOTABUG.  ppc64 doesn't have this I/O port concept, at least not exposed
to userlevel.  The code must be ported to ppc64.
Comment 2 Jakub Jelinek 2007-11-06 12:17:42 EST
Yeah, there is no iopl and friends, only mmapped io, on ppc*, sparc*, s390*
and most other arches.  Only i?86, x86_64, ia64 and alpha have it.
Comment 3 Phil Knirsch 2007-11-07 04:24:14 EST
Ok, thanks, clearly notabug then.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.