Bug 368881 - nss-mdns automatically enables itself
nss-mdns automatically enables itself
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nss-mdns (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 15:49 EST by Nalin Dahyabhai
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 10:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-11-06 15:49:38 EST
Description of problem:
When I install nss-mdns, it automatically adds itself to /etc/resolv.conf.

Version-Release number of selected component (if applicable):
0.10-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Install the package.
2. grep ^hosts: /etc/nsswitch.conf
  
Actual results:
hosts:      files mdns4_minimal [NOTFOUND=return] dns

Expected results:
What I had there before.
Comment 1 Lennart Poettering 2007-11-07 10:45:38 EST
Hmm? Where's the bug?

Don't install nss-mdns if you don't want to use it!
Comment 2 Nalin Dahyabhai 2007-11-07 11:56:50 EST
The bug is that this is inconsistent with how every other nsswitch module is
packaged.  Having the bits installed on the disk does not automatically imply
that they're expected to be used.
Comment 3 Lennart Poettering 2007-11-11 12:06:40 EST
Uh? I mean, we also activate Samba by default when it is installed, don't we?

Just because other nss modules don't enable themselves when installed this
shouldn't be a reason for nss-mdns to not do it.

nss-mdns is about zeroconf, and thus you shouldn't really need to configure it
yourself. It should just work.

If other nss modules don't activate themselves by default when they are
installed then I would say it is a bug in those packages, -- unless of course
they need some very specific configuration before they can be enabled.

I really see no reason why this behaviour of the nss-mdns package should be
considered a bug.

Note You need to log in before you can comment on or make changes to this bug.