Bug 368921 - xresources don't work anymore
xresources don't work anymore
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rxvt-unicode (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 16:28 EST by Frank Schmitt
Modified: 2007-12-20 15:15 EST (History)
0 users

See Also:
Fixed In Version: 8.5a-2.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 15:15:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Schmitt 2007-11-06 16:28:16 EST
Description of problem:

Setting the background pixmap and backspace key with

Rxvt.backgroundPixmap: /usr/share/pixmaps/nebula.xpm
Rxvt.backspacekey: ^h

in ~/.Xdefaults doens't work anymore since the last update of rxvt-unicode. 
Other settings in .Xdefaults still work, e.g.

Rxvt.scrollstyle: plain
Rxvt.cursorColor: yellow

replacing Rxvt.foo with URxvt.foo doesn't help, too.

Version-Release number of selected component (if applicable):

rxvt-unicode-8.4-1.fc7

How reproducible:

always

Steps to Reproduce:
1. echo "Rxvt.backgroundPixmap: /usr/share/pixmaps/nebula.xpm" >> ~/.Xdefaults
2. xrdb -merge ~/.Xdefaults
3. urxvt
  
Actual results:

The specified pixmap isn't used as background image

Expected results:

The specified pixmap should be used as background image
Comment 1 Frank Schmitt 2007-11-06 17:22:30 EST
I reported the problems in #rxvt-unicode in freenode. 

It seems afterimage support is needed for background images now, so the call to 
configure has to be changed.

The problem with Rxvt.backspacekey is unrelated. It is caused by a change in 
the resource handling. One now has to write
Rxvt.backspacekey: \010
Comment 2 Andreas Bierfert 2007-11-07 00:23:28 EST
Thanks for the additional information. While reading the changelog I had a
suspicion in the same direction. I will see that I push rebuilds asap.
Comment 3 Frank Schmitt 2007-12-10 09:33:40 EST
Hmm. Does one month count as ASAP?
Comment 4 Andreas Bierfert 2007-12-10 11:04:12 EST
No. There were some other issues with urxvt that got me distracted. I will see
that I get something out the door today. Thanks for pinging!
Comment 5 Fedora Update System 2007-12-12 14:53:46 EST
rxvt-unicode-8.5a-2.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxvt-unicode'
Comment 6 Fedora Update System 2007-12-12 14:56:50 EST
rxvt-unicode-8.5a-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update rxvt-unicode'
Comment 7 Frank Schmitt 2007-12-13 03:11:01 EST
Thanks, everything works nicely now. As far as I am concernced, the bug can be 
closed.
Comment 8 Fedora Update System 2007-12-20 14:49:51 EST
rxvt-unicode-8.5a-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2007-12-20 15:15:40 EST
rxvt-unicode-8.5a-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.