Bug 36897 - missing entry in listing of an NFS directory served by IRIX
missing entry in listing of an NFS directory served by IRIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-20 17:47 EDT by kehcheng
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-03 08:10:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Test program that reproduces bug (991 bytes, text/plain)
2001-04-25 05:05 EDT, Toralf
no flags Details

  None (edit)
Description kehcheng 2001-04-20 17:47:04 EDT
This is exactly the same bug as #30944, which
was reported more than a month ago but still
is unfixed in 7.1.  I am raising its severity
and priority to high and resubmitting it as
a RedHat 7.1 bug.

One additional comment: to see this bug, you
should do "ls *" or "echo *" in tcsh, or use
the glob() function in perl; doing "ls *"
and "echo *" in bash will not reveal the bug
as bash seems to have its own way of doing
file glob'ing.
Comment 1 Toralf 2001-04-25 05:05:36 EDT
Created attachment 16346 [details]
Test program that reproduces bug
Comment 2 Toralf 2001-04-25 05:08:38 EDT
We have the same problem on our site. I've just attached a test program that
reproduces it.

Also, http://www.fys.uio.no/~trondmy/src/2.4.3/ contains code that fixes the
Comment 3 Mogens Kjaer 2001-05-03 07:39:58 EDT
I've patched the rh71 kernel rpms and made some
new iso files with these. They are available at

Note: They are without any warranty whatsoever,
use them at your own risk!
Comment 4 Arjan van de Ven 2001-05-03 07:57:30 EDT
The patch should also be in kernel version 2.4.3-2.12.1 and later which is in
rawhide / should be there soon
Comment 5 Toralf 2001-05-03 08:10:35 EDT
I actually tried downloading and installing kernel-2.4.3-2.12.1 from rawhide,
but I still had the same problem. Perhaps the patch was introduced after
2.4.3-2.12.1 was released?
Comment 6 Arjan van de Ven 2001-05-21 10:31:23 EDT
2.4.3-5 in rawhide absolutely has the patch. If it still doesn't work it's a
glibc bug. Please reopen in  that case.
Comment 7 Mogens Kjaer 2001-05-22 03:33:49 EDT
Confirmed; it works!
Comment 8 Toralf 2001-05-22 04:32:45 EDT
How about SGI's XFS patches? Are they, or will they be included any time soon.
(Perhaps I should add this as a separate issue?)
Comment 9 Need Real Name 2001-11-21 10:24:37 EST
The same bug apparently reappears in  kernel update 2.4.9-12, RedHat 7.1.   Can
anybody confirm this?

Comment 10 Toralf 2001-11-22 02:26:52 EST
I've encountered similar problems with kernel-2.4.9-13 under Red Hat 7.2, but
the symptoms aren't quite the same; with the original 7.1 kernel, one entry was
missing in readdir() output on some, possibly all, directories, while on
2.4.9-13, *nothing* is returned for large directores. Refer to Bug 55864 for
more info.

Note You need to log in before you can comment on or make changes to this bug.