Bug 369291 - typo in updatedb.conf
typo in updatedb.conf
Status: CLOSED DUPLICATE of bug 242715
Product: Fedora
Classification: Fedora
Component: mlocate (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 19:34 EST by Karl W. Lewis
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 20:11:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl W. Lewis 2007-11-06 19:34:16 EST
Description of problem:

In both Fedora 7 and now in 8 the default updatedb.conf file contains a typo. 
THe exluded directories list contains /sfs as an excluded directory, but /sys is
the intended excluded target.  (Easy to tell because there is no /sfs directory,
and if updatedb wanders into /sys it fails, always.)


Version-Release number of selected component (if applicable):


How reproducible:

Easily.


Steps to Reproduce:
1. Install Fedora 7 or 8 and run `updatedb` as root.
OR
2. Inspect /etc/updatedb.conf in a freshly installed system.

  
Actual results:

until /sfs is replaced with /sys updatedb fails.

Expected results:
updatedb should run without errors.

Additional info:

This is easy to fix, and easy to find references to in Google, but it might be
frustrating to newbies....

I've listed the x86_64 platform because that's where I've seen this, in both 7
and 8, it could well be in the others, too, but I haven't looked.
Comment 1 Miloslav Trmač 2007-11-06 20:11:45 EST
Thanks for your report.

As https://bugzilla.redhat.com/show_bug.cgi?id=242715#c21 says, /sfs is separate
from /sys.  The invalid dentry in /sys should be fixed in the kernel, adding
/sys is just a work-around.


*** This bug has been marked as a duplicate of 242715 ***

Note You need to log in before you can comment on or make changes to this bug.