This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 369341 - prelink gets selinux violation on vdso-sysenter.so
prelink gets selinux violation on vdso-sysenter.so
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-06 21:43 EST by Daryll
Modified: 2007-12-05 15:45 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.0.8-58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-05 15:45:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
selinux information (2.66 KB, text/plain)
2007-11-06 21:43 EST, Daryll
no flags Details

  None (edit)
Description Daryll 2007-11-06 21:43:48 EST
Description of problem:
I installed F8 and later decided to turn on selinux. 
Now when prelink runs, it generates a selinux violation complaining about
vdso-sysenter.so.


Version-Release number of selected component (if applicable):
kernel-2.6.23.1-42.fc8

How reproducible:
This seems to be happening with each kernel that was installed every time
prelink runs.

Steps to Reproduce:
run setroubleshooter
wait for prelink to run
look at results
  
Actual results:
selinux kills prelink because of the violation

Expected results:
prelink should run with no selinux violations


Additional info:
Neither the vdso directory nor the so's in them see to have any secontext
information associated with them.
Comment 1 Daryll 2007-11-06 21:43:48 EST
Created attachment 249831 [details]
selinux information
Comment 2 Chuck Ebbert 2007-11-21 14:19:14 EST
Dan, do we need to add selinux context for these files?
Comment 3 Daniel Walsh 2007-11-21 18:09:47 EST
Fixed in selinux-policy-3.0.8-58.fc8

Note You need to log in before you can comment on or make changes to this bug.