Bug 36942 - SMC 9332BDT EtherPower 10/100 PCI network card is misdetected
SMC 9332BDT EtherPower 10/100 PCI network card is misdetected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-20 20:51 EDT by Brian Kasper
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:32:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of lspci command (903 bytes, text/plain)
2001-04-21 12:59 EDT, Brian Kasper
no flags Details
Output of 'lspci -n' command (450 bytes, text/plain)
2001-04-21 13:00 EDT, Brian Kasper
no flags Details
Output of 'lspci -v' command (3.45 KB, text/plain)
2001-04-21 13:01 EDT, Brian Kasper
no flags Details

  None (edit)
Description Brian Kasper 2001-04-20 20:51:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; U)


In graphical custom install, the "tulip" module is installed for use with an SMC 9332BDT EtherPower 10/100 PCI NIC.  The eth0 device
then fails to start upon boot.  Changing "alias eth0 tulip" to "alias eth0 de4x5" in /etc/modules.conf and running depmod fixes the
problem, but novice users wouldn't know (a) that they should do this, or (b) how to do this

Reproducible: Always
Steps to Reproduce:
1. Insert SMC 9332BDT EtherPower10/100 PCI NIC into i386 system
2. Perform graphical "custom install" of Red Hat 7.1
3. Watch the system hang for a couple of minutes as it tries to start eth0
	

Actual Results:  I'm also using DHCP, which made my system hang for a LOOONG time on boot.  dhcpcd would always dump core
on a "signal 2" error (I'm assuming this is because eth0 wasn't up).

Expected Results:  The de4x5 module should be used with this card.  After I manually changed the module specified in /etc/modules.conf, the
system works beautifully.  The installer should be modified to select the correct module.

I'm also booting Windows 98 and Windows NT on the system, so I know it's nothing weird about the card (it works
flawlessly under all 3 operating systems now).
Comment 1 Brent Fox 2001-04-21 08:57:03 EDT
This is more of a kudzu issue, since kudzu does the hardware detection for both
the installer and once the OS is installed.  Can you go to VC2 and type lspci -n
and lspci -v and send us the output of both of those?  Once we have the
information from the card, we can update the table in kudzu that associates
cards with their specific drivers.

I'm changing the component to kudzu.
Comment 2 Brian Kasper 2001-04-21 12:59:33 EDT
Created attachment 15966 [details]
Output of lspci command
Comment 3 Brian Kasper 2001-04-21 13:00:33 EDT
Created attachment 15967 [details]
Output of 'lspci -n' command
Comment 4 Brian Kasper 2001-04-21 13:01:14 EDT
Created attachment 15968 [details]
Output of 'lspci -v' command
Comment 5 Brian Kasper 2001-04-21 13:03:22 EDT
I'm not sure what the "VC2" in "Can you go to VC2 and type lspci -n
and lspci -v and send us the output of both of those?" means, but
I've attached 3 files containing the output of 'lspci', 'lspci -n', and
'lspci -v' to the bug.  All commands were run as root at runlevel 3.
Hope this helps.  -Brian
Comment 6 Bill Nottingham 2001-04-21 16:05:36 EDT
Assigning to kernel. tulip should work fine for that card.
Comment 7 Need Real Name 2001-04-29 13:15:28 EDT
This problem is not just for the EtherPower Card.

We have the same problem with the on-board card for Tyan s2510ng. The on board 
nic's are based on the intel 82559 chip. A look at the detected cards shows 
that kudzu blew-it again (from lspci -v):

Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
...
Ethernet controller: Intel Corporation 82557 [Ethernet Pro 100] (rev 08)
...

Both of these are obviously wrong, because the card uses the intel 82559 chip. 
The effect is that NIS and any loading of the card causes the operating system 
to hang, and report: 

eth0: Card reports out of resources
eth1: Card reports out of resources



Comment 8 Arjan van de Ven 2001-04-29 13:31:42 EDT
lawrencefry@home.com: that is a totally different bug, as it is a totally
different driver.  Please open a separate bug for this.

Note You need to log in before you can comment on or make changes to this bug.