Bug 369611 - yum upgrade with selinux-policy-strict installed fails
yum upgrade with selinux-policy-strict installed fails
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 09:11 EST by Bruno Wolff III
Modified: 2008-08-06 10:46 EDT (History)
1 user (show)

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 14:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno Wolff III 2007-11-07 09:11:56 EST
Description of problem:
I tried doing a yum upgrade from f7 to f8 and it initially failed complaining
about being unable to resolve a dependency for selinux-policy-strict.

Version-Release number of selected component (if applicable):
I am not sure this applies as selinux-policy-strict isn't in f8

How reproducible:
I am not sure. I was able to upgrade with a work around and I don't currently
have another system that I am able to test this on.

Steps to Reproduce:
1. Install selinux-policy-strict on an f7 system.
2. yum upgrade
3.
  
Actual results:
The upgrade error out.

Expected results:
Upgrade should run to completion.

Additional info:
Since I was actually using the targeted policy, I just removed the strict and
mls policies with rpm and then did the yum upgrade, which worked.
I am guessing this problem is related to strict being subsumed by targeted and
that perhaps targeted should obsolete strict in f8. Though I can imagine that
things may not be that simple.
Comment 1 Daniel Walsh 2007-11-08 11:10:34 EST
Fixed in selinux-policy-3.0.8-48
Comment 2 Daniel Walsh 2008-01-30 14:05:47 EST
Bulk closing a old selinux policy bugs that were in the modified state.  If the
bug is still not fixed.  Please reopen.
Comment 3 Aleksander Adamowski 2008-08-06 10:43:05 EDT
What should one do if one actually needs the strict policy?

Has this policy been discontinued? Moved to a different package?

The http://fedoraproject.org/wiki/Bugs/F8Common page states that:
"...the new consolidated selinux-policy-targeted package does not properly obsolete the old strict package..." 

I have the selinux-policy-targeted package installed, but I don't see any trace of strict policy on my system. The /etc/selinux/strict directory doesn't exist, only /etc/selinux/targeted.
Comment 4 Aleksander Adamowski 2008-08-06 10:46:04 EDT
BTW, the release notes for Fedora 8
(http://docs.fedoraproject.org/release-notes/f8/en_US/sn-Security.html#SELinux)
do not mention anything about this mysterious disappearance of strict policy
from Fedora.

I think it ought to be documented there. Notifying users of such changes is the
very reason for having release notes in the first place.

Note You need to log in before you can comment on or make changes to this bug.