Bug 369761 - device-mapper multilib problem on ppc (breaks lvm mirrors)
device-mapper multilib problem on ppc (breaks lvm mirrors)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper (Show other bugs)
5.1
All Linux
high Severity high
: ---
: ---
Assigned To: Milan Broz
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 10:19 EST by Bryn M. Reeves
Modified: 2013-02-28 23:05 EST (History)
13 users (show)

See Also:
Fixed In Version: RHBA-2008-0081
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:44:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
separate subpackages patch to device-mapper.spec (2.70 KB, patch)
2007-11-07 10:33 EST, Bryn M. Reeves
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2007-11-07 10:19:54 EST
Description of problem:
The device-mapper packages shipped in RHEL5 have a problem on multilib ppc systems.

device-mapper contains several components:
    
    shared & static libraries
    docs & header files
    binaries installed in /sbin

Both the ppc and ppc64 device-mapper RPMs are shipped in the current RHEL5
releases. The install ordering on PPC installs the 64-bit version after the
32-bit version, overwriting the binaries in /sbin.

This causes a problem since the lvm2 package provides a plugin that is used by
one of the daemons installed by the device-mapper-package (dmeventd and the
libdevmapper-event-lvm2mirror.so plugin). Only the 32-bit lvm2 packages are
shipped, so only the 32-bit plugin is installed. This then fails when a mirrored
logical volume is created because the event daemon that monitors it is a 64-bit
process.

Version-Release number of selected component (if applicable):
1.02.13-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Install a ppc system from RHEL-5/RHEL-5.1
2. Attempt to create a mirrored logical volume, e.g.:

    lvcreate -v -n mirror0 -L 100M -m1 tg0

    (tg0 can be any volume group with at least two PVs)


Actual results:
# lvcreate -n mirror0 -L 100M -m1 tg0
  tg0-mirror0: event registration failed: Can not access a needed shared library
  Logical volume "mirror0" created


Expected results:
# lvcreate -v -n mirror0 -L 100M -m1 tg0
  Logical volume "mirror0" created

Additional info:
This was addressed in Fedora by splitting the device-mapper package up into
separate device-mapper, device-mapper-libs, and device-mapper-devel
sub-packages. Tested successfully on RHEl5 versions of these packages.
Comment 1 Bryn M. Reeves 2007-11-07 10:33:23 EST
Created attachment 250251 [details]
separate subpackages patch to device-mapper.spec

Testing specfile patch based on the changes from the Fedora version of these
packages. Built in brew & hand-tested on PPC.

Note the patch also includes changes to Release: that will need to be modified
before this is committed.
Comment 2 RHEL Product and Program Management 2007-11-07 10:34:39 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 errata-xmlrpc 2008-05-21 12:44:17 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0081.html

Note You need to log in before you can comment on or make changes to this bug.