This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 36978 - apm suspend crash on wakeup with a Toshiba Tecra 8100
apm suspend crash on wakeup with a Toshiba Tecra 8100
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 10:11 EDT by Alain Wenmaekers
Modified: 2014-03-16 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 17:46:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alain Wenmaekers 2001-04-21 10:11:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)


suspending the laptop with apm --suspend works (The control led confirms
this). When powering up, all I get is a blank screen (keyboard doesn't
work....not even the powerbutton. All that is possible is using the
hard-reset).
I'm using a Toshiba Tecra 8100 with RH7.1 installed on the loop device (on
a vfat partition). apm --suspend however did work with RH7.0 in the exact
same configuration.

Reproducible: Always
Steps to Reproduce:
1. apm--suspend
2. power back on
3.
	

Actual Results:  system crashes. Keyboard and powerbutton are not
responsive to input. Power Led stays on.

Expected Results:  system-wake up 

Toshiba Tecra 8100
256 Mb RAM
HD 6G (3+3 vfat, the Redhat.img is on partition 2 with a size of 2G)
Comment 1 Alain Wenmaekers 2001-04-22 07:15:05 EDT
downgrading to the apm rpm from RH7.0 solves the problem
Comment 2 Need Real Name 2002-02-04 16:20:10 EST
This bug looks old, but it's still open, so here's a comment.

On the Dell Inspiron, this happens when DRI is enabled in X
and the machine is suspended---it does not restore.  See the 
information on suspending in the Linux-Dell-Laptops FAQ at
http://www.whacked.net/ldl/faq

With the latest 7.1 updates for X and the kernel, this problem
has re-appeared since DRI is now enabled by default.  I'll
probably submit a new bug report.
Comment 3 Alain Wenmaekers 2002-02-04 16:40:32 EST
The laptop is still running RH7.1 (but not on an vfat partition anymore).
The apm problems still occurs (even with the RH7.0 apm RPM... I though for a 
moment it worked better, but I was wrong)

Because of the previous comment I tried some suspends without X... and it 
seemed to work.
The RH7.0 installation (which didn't have the problem), used a Xfree3.x X-
server not included in RedHat.

So I think the problem can be traced back to X.
Comment 4 Bernhard Rosenkraenzer 2002-02-26 12:47:22 EST
Are you still seeing this with the current version?
Comment 5 Need Real Name 2002-02-26 15:28:58 EST
not suring if you're asking about this question as regards Toshiba or Dells,
but this is still a problem on the Dell Inspiron.  one thing to add is that the
module
agpgart cannot be loaded *before* doing the suspend (i'm not sure what
the relationship is between DRI and agpgart).
Comment 6 Alain Wenmaekers 2002-02-26 16:25:03 EST
DRI and/or AGPGART are not loaded on the Toshiba 8100 (the S3 Savage only has 
2D accelleration in linux), also no kernel modules are loaded for X.
I am not really able to try a new RH version on this machine because it's now 
used as a "stable" development platform.
If I have time this week I will try the newer X version. I will keep you posted.

Comment 7 Mike A. Harris 2002-06-19 14:03:35 EDT
If downgrading APM solved the problem before, then it most likely is not
an XFree86 issue.  APM related problems usually are not XFree86 related,
but tend to be hardware bugs or BIOS bugs which potentially can and sometimes
do get worked around in kernel updates or fixed in BIOS flash updates.
Also, kernel bugs, apmd bugs.  XFree86 bugs do pop up, but the are indeed
rare.  Almost all APM bugs that get resolved are not resolved via XFree86
updates.

Reassigning to apmd

Comment 8 Bill Nottingham 2005-02-02 17:46:54 EST
Closing out bugs on older unsupported releases. Apologies for any lack
of response. Please reopen if it persists on current releases such as
Fedora Core 3.

Note You need to log in before you can comment on or make changes to this bug.