Bug 369781 - zip segfaults when working with a file larger than 4GB
zip segfaults when working with a file larger than 4GB
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: zip (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 10:32 EST by Radek Bíba
Modified: 2008-04-17 07:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 07:43:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Bíba 2007-11-07 10:32:08 EST
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
zip-2.31-1.2.2

How reproducible:
Always, but only on i368 (and possibly other 32-bit arches). x86_64 gives this
output: zip error: Entry too big to split, read, or write (file exceeds Zip's
4GB uncompressed size limit)

Steps to Reproduce:
e.g.:
1. dd if=/dev/zero of=testfile bs=1M count=4097
2. zip testfile.zip testfile
  
Actual results:
Segmentation fault

Expected results:
Hmm, I don't know :) . Either the message it prints on x86_64, or just success.
The question is if zip is able to work with >4GB files or not. In either case,
it shouldn't crash.

Additional info:
(gdb) bt
#0  0x4c930353 in strlen () from /lib/libc.so.6
#1  0x4c902fac in vfprintf () from /lib/libc.so.6
#2  0x4c9037c2 in buffered_vfprintf () from /lib/libc.so.6
#3  0x4c8ff6ef in vfprintf () from /lib/libc.so.6
#4  0x4c9a4de5 in __fprintf_chk () from /lib/libc.so.6
#5  0x0804918c in zipwarn (a=0x805729a "file too large: ",
    b=0x128 <Address 0x128 out of bounds>) at zip.c:338
#6  0x0805253f in procname (n=0xbfb5cb4e "ziptest", caseflag=0) at unix/unix.c:214
#7  0x0804a71c in main (argc=Cannot access memory at address 0x128
) at zip.c:1468
#8  0x4c8d9dec in __libc_start_main () from /lib/libc.so.6
#9  0x080490c1 in _start ()
Comment 1 Ivana Varekova 2008-04-17 07:43:09 EDT
I can't reproduce this problem, so I'm closing this bug - please feel free to
reopen if you see the bug. Thanks.

Note You need to log in before you can comment on or make changes to this bug.