Bug 36988 - New installation and/or upgrade failed
New installation and/or upgrade failed
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 11:33 EDT by Thomas Chao
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-09 10:56:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Chao 2001-04-21 11:33:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


The released version 7.1 failed both on upgrade and fresh installation

Reproducible: Always
Steps to Reproduce:
1.Update or w/ new installation
2.Choose the custom packages
3.system crashed during installation
	

Actual Results:  Two results had happened:

1. the system crashed during installation (6 out of 8 trials)
2. 2 out of 8 times has the system up, but lost mouse control and X will 
not work!

Expected Results:  either upgrade and/or installation should complete 
without a problem, because I have no problem doing that from 7.0 to 7.1 
Beta 1 and Beta2.  (I have some problem in Beta 1, but not as this release 
that failed each time).

This is the crash dump:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in 
doInstall
    (p, self.intf.messageWindow, pkgTimer))
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1564, in 
instCallback
    fn = self.method.getFilename(h, pkgTimer)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 87, in 
getFilename
    isys.umount("/mnt/source")
  
File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys
.py", line 140, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
what: /mnt/source
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>
Comment 1 Brent Fox 2001-04-21 12:51:19 EDT
This looks like a dupe of bug #25449.  Did you go to VC2 and look around in
/mnt/source?  If so, if you were still in that directory when the installer
tries to unmount cd1, the installer can't unmount it because it is in use.
Comment 2 Thomas Chao 2001-04-23 08:50:08 EDT
All of the installation happened in an automated process.  The system crashed 
w/o stating it were unable to unmount a CD.  If this is the case, how can I 
avoid it from happening?  Any suggestion to test it again?  

Also, for the 2 out of the 8 that success, why do I lost mouse and have a 
disable X (BTW, I am OK in Beta 2)?  Any suggestion on this one?

Thanks
Comment 3 Brent Fox 2001-04-24 12:00:54 EDT
When you say 'automated', do you mean kickstart?  I don't know about the mouse
problem...I want to figure out the main problem first.
Comment 4 Thomas Chao 2001-04-24 15:58:20 EDT
my 'automated' means boot installation from CD-ROM, not the automated boot 
installation using kickstart.  Sorry for the confusion!

Any suggestion for further testing?  (Currently, I re-installed the Beta 2, 
then update some new files and avoid anaconda and XFree86 4.0.3, and so far the 
machine is OK!)
Comment 5 Brent Fox 2001-04-24 16:08:50 EDT
So, on the times when the installer crashed, had you previously pressed
<Ctrl><Alt><F2> and gone into the /mnt/source directory?
Comment 6 Thomas Chao 2001-04-25 09:10:01 EDT
No, I did not do anything!  It crashed in the middle of installing the rpm packages.  (After I custom the packages to install, it then went into the mode of 
installing all the packages I picked.  In the middle of it, it crashed by itself). 

I will find another machine to test it again.

Comment 7 Brent Fox 2001-04-27 11:23:07 EDT
Are you sure that the cd's are ok?  Maybe something went wrong during the
download...
Comment 8 Thomas Chao 2001-04-27 16:34:43 EDT
That's possible, because I have several MD5 programs and they had different 
outputs!  I am awaiting the official CD next week to give my final test.
Comment 9 Staci Schipporeit 2001-04-27 21:07:14 EDT
I think I am having the same problem. Here's the error message:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in
__call__
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in
doInstall
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1564, in
instCallback
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 84, in
getFilename
IOError: (0, 'Error')

Local variables in innermost frame:
f: <closed file '/mnt/source/.disc1-i386', mode 'r' at 9b0c980>
key: .disc1-i386
h: <header object at 844efc8>
timer: <timer.Timer instance at 9a54408>
self: <image.CdromInstallMethod instance at 82368f8>
timestamp: 986787650.210260


ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I25
sS'width'
p11
I80
sS'helpCb'
p12

<failed>

This happens about 65% of the way through a server installation. I'm installing 
from the redhat CD, version 7.1, not an upgrade.
Comment 10 Brent Fox 2001-04-30 12:14:58 EDT
staci, I would recommend checking the md5sums of the ISO's and make sure that
everything went ok during the download.  Press <Ctrl><Alt><F3> and
<Ctrl><Alt><F4> and see if you see any errors like "cdrom seek error" or
something like that.  That's almost always an indication of bad cd's.


tomchao, I'm putting this bug into 'needinfo' state until you get a chance to
test with the official cd.  I have a feeling that bad cd's are the problem here.
Comment 11 Thomas Chao 2001-04-30 12:20:53 EDT
OK.  I am still waiting for the CD to arrive.  I will update this one when I 
tested those certified CD.
Comment 12 Staci Schipporeit 2001-04-30 12:47:58 EDT
The install is now dying every time with a signal 11 after formatting the 
partitions, as the package install progress window comes up. 
<ctrl><alt><f4> brings up a series of messages something like this:
I/O Error dev 16:00 (hdc): tray open
hda: timeout waiting for DMA

Does that mean it thinks my CD tray is open?  I'm using an official 7.1 cd 
purchased directly from RedHat.
Comment 13 Brent Fox 2001-05-01 12:01:35 EDT
staci, it looks like your cdrom drive doesn't like dma transfers.  This is more
of a kernel problem.  Try booting with 'linux ide=nodma' at the boot screen.
This will tell the kernel not to use dma transfers with all ide devices.  This
will mean that the hard drive transfer rate will not be as fast as it could, but
on the other hand, it should allow your cdrom to work.  Does this help?
Comment 14 Staci Schipporeit 2001-05-02 11:25:03 EDT
thanks, that did it!
Comment 15 Brent Fox 2001-05-02 15:09:28 EDT
Yeah, this is a bug the that kernel team knows about.  They are assembling a
list of devices not to use DMA transfers on, so that this doesn't happen in the
future.
Comment 16 Brent Fox 2001-05-02 15:10:13 EDT
Putting in 'Needinfo' state until tomchao's CDs arrive.
Comment 17 Thomas Chao 2001-05-09 10:29:48 EDT
I've tested w/ the MD5SUMS CDs and these are my findings:

1. The installation have minor problems, but by trying multiple times, my 
system crash did not occured!
2. with either upgrade or fresh install, X server and mouse would not work!  I 
patched the new Xconfigurator and mouseconfig, but they are still not working.
My solution was to remove them altogether and install the rpm package from the 
Beta 2.  They works right away.  I then pathed them w/ the latest rpm patches 
from RH site.

I think you can close this bug.  I believe the X and mouse have been reported 
elsewhere.
Comment 18 Brent Fox 2001-05-09 10:56:39 EDT
Ok.  Hey guys, thanks for working with us on this issue.

Note You need to log in before you can comment on or make changes to this bug.