Bug 36996 - OpenGL programs generator a glide error on Voodoo4/5 cards
OpenGL programs generator a glide error on Voodoo4/5 cards
Status: CLOSED DUPLICATE of bug 36158
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 14:32 EDT by Jim Phillips
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-04 03:42:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XMMS OpenGL Spectrum Analyzer Visualization Plugin (113.51 KB, image/png)
2001-04-22 13:07 EDT, Jim Phillips
no flags Details
X Server log as requested (21.48 KB, text/plain)
2001-04-28 14:17 EDT, Jim Phillips
no flags Details
XF86Config-4 as requested (1.86 KB, text/plain)
2001-04-28 14:19 EDT, Jim Phillips
no flags Details

  None (edit)
Description Jim Phillips 2001-04-21 14:32:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2-0.1.49 i686; en-US; 0.7)
Gecko/20010316


The libglide3.so in XFree86-libs-4.0.3-5 has a bug when used on a Voodoo4/5
graphics accellerator w/ OpenGL software.  Specifically, the error message is:
gd error (glide): gd error (glide): grSstSelect: non-existent SSTgd error
(glide): grSstSelect: non-existent SSTSegmentation fault (core dumped)

A good example for reliably generating this error is tuxracer.

Reproducible: Always
Steps to Reproduce:
1.  Combine the libglide3.so from XFree86-libs-4.0.3-5 with a Voodoo5 card.
2.  Run an OpenGL program.
	

Actual Results:  The above error

Expected Results:  The program should run.

There is an RPM for SuSe linux that contains just the libglide3.so compiled
w/ proper 3dFX support, however even that libglide3 isn't flawless.  Better
to fix the XFree86-libs version.
Comment 1 Mike A. Harris 2001-04-21 15:02:56 EDT
There are *two* glide libraries for XFree86-4.0.3.  One is for Voodoo 3,
and the other for Voodoo 5.  I dunno which one Voodoo 4 is supposed to use
however as I have no 3dfx cards to test with.  Upon installation, there
is a symlink pointing from:

/usr/lib/libglide3.so.3.10.0 to /usr/lib/glide/libglide3-v3.so

You need to manually change the symlink to point to the voodoo 5 library
by doing: "cd /usr/lib ; ln -sf glide/libglide3-v5.so libglide3.so.3.10.0"

Make sure the link was made correctly, run "ldconfig", and it should work.
This should all be done by Xconfigurator I suppose, so I'm reassigning it
there.
Comment 2 Jim Phillips 2001-04-21 15:53:20 EDT
Well, I did as you suggested and linked /usr/lib/glide3/libglide3-v5.so to
/usr/lib/libglide3.so.3.10.0 and I no longer get that error.  Instead I get some
very pretty but very non-working results when I run an OpenGL program.  To
describe it, it looks something like the northern lights..  A very colorful blob
starting from a single pixel in the lower left corner of the display window and
expanding up and to the right (kind of like a spotlight) would be a more accure
description.  I haven't got the slightest idea why, but that's what it's doing now.
Comment 3 Jim Phillips 2001-04-22 13:07:32 EDT
Created attachment 16025 [details]
XMMS OpenGL Spectrum Analyzer Visualization Plugin
Comment 4 Jim Phillips 2001-04-22 13:09:12 EDT
The above attachment is a screen capture of a window that exibits these
problems.  XMMS has an OpenGL Spectrum Analyzer as one of its visualization
plugins.  You'll be able to view the expected results of running that. 
error.png shows what I get.
Comment 5 Mike A. Harris 2001-04-24 03:20:14 EDT
Please attach a copy of your XF86Config-4 and your X server log using
the "Create a new attachment" link below.
Comment 6 Jim Phillips 2001-04-28 14:17:28 EDT
Created attachment 16727 [details]
X Server log as requested
Comment 7 Jim Phillips 2001-04-28 14:19:00 EDT
Created attachment 16728 [details]
XF86Config-4 as requested
Comment 8 Mike A. Harris 2001-05-04 03:43:36 EDT

*** This bug has been marked as a duplicate of 36158 ***

Note You need to log in before you can comment on or make changes to this bug.