Bug 369961 - Build error with vlc and compat-wxGTK26 on F-7 (it works on F-8)
Summary: Build error with vlc and compat-wxGTK26 on F-7 (it works on F-8)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: compat-wxGTK26 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-07 17:27 UTC by Nicolas Chauvet (kwizart)
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 16:47:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Chauvet (kwizart) 2007-11-07 17:27:59 UTC
Description of problem:
vlc 0.8.6c still use compat-wxGTK26 (next vlc version 0.9.0 will drop support of
wxGTK for qt4 )

Version-Release number of selected component (if applicable):
rpm -q compat-wxGTK26-devel
compat-wxGTK26-devel-2.6.3-2

How reproducible:

Expected results: 


Additional info: Maybe a syncr with compat-wxGTK26 from F-8 will be enought. But
I wonder if updating to 2.6.4 will not be better...?!

Could you warn me before you push such update so I can checks if vlc for F-7 can
be rebuilt ?

Comment 1 Michael Schwendt 2007-11-07 19:16:25 UTC
What build error?

compat-wxGTK26 is the same on F-7 and F-8 except for some
bug-fixes. It is not wxGTK 2.6.3, but ~2.6.3.2.

wxGTK 2.6.4 has been released without news. It doesn't contain
many changes, but still we would need to test Audacity with it.


Comment 2 Nicolas Chauvet (kwizart) 2007-11-09 12:50:56 UTC
Sorry i'm running low of disk space with my "transition buildsys" to run a mock
build with vlc on f7 x86_64... So If you want to check yourself until I can
so... You can take the last vlc srpm from livna...



Comment 3 Michael Schwendt 2007-11-09 14:56:19 UTC
It fails in vlc-0.8.6c/modules/codec/dirac.c, because apparently
dirac-devel has been updated to 0.8.0 in October, while vlc depends
on an older API.


Comment 4 Nicolas Chauvet (kwizart) 2007-11-09 15:08:07 UTC
well, you really should take the F-7 srpms from livna: (as there is a lot of
patches)
Actually dirac 0.8.0 is only in F-8 . I plan to have it for F-7 too but it has
not hit the repository (even F-7 testing)

From F-7 - dirac should still be 0.7.0

Comment 5 Michael Schwendt 2007-11-09 15:48:31 UTC
I do use the F7 src.rpm from livna

dirac 0.8.0 _is_ in F7 updates-testing:

$ yum list dirac-devel
Installed Packages
dirac-devel.i386                         0.7.0-1.fc7            installed       
Available Packages
dirac-devel.i386                         0.8.0-2.fc7            updates-testing 

After downgrading to 0.7.0, the wxWidgets GUI compiles fine on i386.
Comment 1 holds true.


Comment 6 Nicolas Chauvet (kwizart) 2007-11-09 16:47:39 UTC
My bad, it works (tested with mock on x86_64 F-7)
(but i've experienced the problem with rpmbuild so i wonder if the problem was
due to a multilib conflict or something else...)



Comment 7 Michael Schwendt 2007-11-09 18:05:15 UTC
I prefer rpmbuild+rpmdevtools.

A test-update to wxGTK 2.6.4 for F7 and F8 has been requested
anyway:

F7: http://koji.fedoraproject.org/koji/buildinfo?buildID=23775
F8: http://koji.fedoraproject.org/koji/buildinfo?buildID=23774



Note You need to log in before you can comment on or make changes to this bug.