Bug 37017 - Installer indicates Win98 drive is corrupt
Installer indicates Win98 drive is corrupt
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-04-21 16:01 EDT by Lee A. Wentzel
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-05-20 19:52:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Lee A. Wentzel 2001-04-21 16:01:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; MSOCD; 

Have two hard drives, first one with Windows 98.  When installing Linux 
7.1 it indicates hda (first hard drive) is corrupt.  I fdisked and 
reformated the Windows drive with both FAT32 and FAT16.  I even did a 
FDISK /MBR to ensure the drive was set up properly.  Each time 7.1 
indicated the Windows drive was corrupt.  Attempted to reinstall 7.0 and 
had NO difficulties at all.

Reproducible: Always
Steps to Reproduce:
1.Pulled all particians. (both Windows & Linux drive)
2.FDISKed first drive for Windows 98 using FAT32.
3.Formated and reloaded Windows 98.
4.Verified it was fully functional.  (It was)
5.Attempted to load RH 7.1.
6.Recieved error indicating that hda was corrupted.
7.Continued with install of work station.
8.Choose to have RH to not initialise HDA.
9.Installed 7.1 on hdb.
10.Rebooted when completed with install.
11.System only shows LINUX as an option to boot.
12.Pulled all particians.
13.Repeated all steps, but used FAT16 on Windows hard drive.
14.Same failure.
15.Repeated all steps, again using FAT16.
16.This time installed 7.0.
17.No errors found.
18.Installed was flawless.
19.System dual boots as it should.

Actual Results:  When installing 7.1 the system would not recognize the 
Windows hard drive.  When installing 7.0 everything worked flawlessly.

Expected Results:  I expected 7.1 to work as flawlessly as 7.0 did.

My initial hard drive is a 1.2 GB Seagate.  My second hard drive which I 
was using for the Linux install was a 5 GB Western Digital.
Comment 1 Michael Fulbright 2001-04-23 12:17:07 EDT
What is the exact wording of the message which indicates the drive is corrupt?
Comment 2 Brent Fox 2001-05-07 16:39:57 EDT
Closing due to inactivity.  Please reopen if you have more information.
Comment 3 Lee A. Wentzel 2001-05-07 16:52:31 EDT
I have decided to use a stable version of RH reverting back to 7.0.  There is a problem, however I haven't had the time to do your work for 
you.  The exact error indicated the hardrive (hda) was corrupted and would need to be initiallized.  It then asked me if I wanted to proceed.  I 
said No.  It waited forever and came up with the same error indicating that hda was corrupted and would need to be initiallized and again it 
asked me if I wanted to proceed.  I said no.  At that point it found my second hard drive and proceeded to partician it and set it up.  When it 
was done, Lilo didn't even offer me a choice for Windows.  RH 7.0 had no problem at all.
Comment 4 Brent Fox 2001-05-20 19:52:35 EDT
It sounds like the installer couldn't read the partition table on the
disk...that might explain why Lilo didn't give you the option to set up a
windows partition, because it didn't find any partitions at all.  I can't really
explain why this happened, except for the fact the 2.4 kernel is more strict in
it's reading of disk geometry.  The only thing I can think of to try is booting
the installer with the 'linux expert' boot option.  This will cause the kernel
to be more lenient in it's disk geometry rules.  If you feel like trying that,
please reopen the bug and tell us if that changed anything.  Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.