Bug 37024 - Sun Java JDK 1.3 interpreter does not work
Sun Java JDK 1.3 interpreter does not work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 16:45 EDT by Need Real Name
Modified: 2016-11-24 10:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-22 10:41:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-21 16:45:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.1smp i686)


JDK 1.3 was working good on Redhat 7.0, but in Redhat 7.1
First the compiler was not working until I made a copy the /bin/cut to the
/usr/bin directory.
Second.- Any class file ins not able to run with the java interpreter,
seems like the process gets frozen.

Reproducible: Always
Steps to Reproduce:
1. Copy the /bin/cut file to /usr/bin directory
2. Compile any .java file with javac compiler from j2sdk 1.3
3. Run any .class with the java interpreter
	

Actual Results:  The compiler does not work until I copy the cut file
The java interpreter does not run any program

Expected Results:  Compiler and interpreter working good like they do in
Redhat 7.0
Comment 1 Need Real Name 2001-04-21 18:08:17 EDT
I am experiencing this problem with Red Hat Linux 7.1 and JDK 1.3.0_02 as well.
In the process list the java interpreter is listed as [java <defunct>] and in a
zombie state.
Comment 2 Jakub Jelinek 2001-04-22 05:42:55 EDT
See RELEASE-NOTES:

    o Some Java JVMs (both from Sun and IBM) don't work with the new
      floating stack feature of the i686 version of glibc.  The failures
      are due to programming assumptions in the JVMs that are now invalid.
      JVM vendors are working on making the necessary corrections.  Until
      corrected JVM packages are available, you may force glibc to use the
      deprecated stack model by setting the following environment variable:

                          LD_ASSUME_KERNEL=2.2.5

As for /bin/cut vs. /usr/bin/cut, you either have to make a symlink
or adjust JDK scripts.
Comment 3 Need Real Name 2001-04-22 10:41:14 EDT
I have had good luck using the IBM JVM instead of the Sun JVM after coming
across this bug in my 7.1 machine.

Note You need to log in before you can comment on or make changes to this bug.