Bug 37030 - XMMS "Always on top" conflicts with "+DIR" after upgrade to Red Hat 7.1
XMMS "Always on top" conflicts with "+DIR" after upgrade to Red Hat 7.1
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-21 21:44 EDT by rastor
Modified: 2014-03-16 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-21 22:12:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rastor 2001-04-21 21:44:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i586)


After upgrading to Red Hat 7.1, XMMS "always on top" feature conflicts with
the the "+DIR" functionality of the XMMS playlist.  Attempts to mouseclick
in the directory chooser window cause a beep.

Reproducible: Always
Steps to Reproduce:
1. run XMMS
2. turn on "always on top" (ctrl-A)
2. open playlist editor
3. click and hold "+FILE" button; release on "+DIR"
4. attempt to select a directory

Actual Results:  I heard a beep through the PC speaker and the directory
selection window did not respond.

Expected Results:  I should have been able to select a directory and add it
to the playlist.

The keyboard works, it is only the mouse that fails, and only when "always
on top" is turned on.  Also, windows sometimes "get on top" of XMMS,
although I am unable to reliably reproduce this.
Comment 1 rastor 2001-04-21 22:09:16 EDT
I have discovered how to reliably get a window "on top" of XMMS.
1. Run Netscape (I used version 4.76)
2. open a find window (alt-F)
3. close the find window
4. click anwhere in the browser window
Comment 2 Thomas Nilsson 2001-12-21 22:12:37 EST
I'll assume you're using Sawfish, so..

This is caused by a problem with Sawfish, the stacking gets confused.

Reference:
http://bugs.xmms.org/show_bug.cgi?id=27
http://bugzilla.gnome.org/show_bug.cgi?id=48412

Workaround:
In the misc of the sawfish config. an option called "Keep transient windows
stacked above: ---", set this to "none" to make the problem go away.

Future:
It's fixed in the sawfish cvs, if a new version is out or not, I do not know.
Comment 3 rastor 2001-12-22 01:01:15 EST
Yep, that fixed it... this has been a minor annoyance for me for the last 8
months.  Thanks for the solution!

Note You need to log in before you can comment on or make changes to this bug.