Bug 37031 - Seawolf can't nfs export vfat partition
Summary: Seawolf can't nfs export vfat partition
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-22 04:47 UTC by Jay Berkenbilt
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-04-23 15:21:18 UTC


Attachments (Terms of Use)

Description Jay Berkenbilt 2001-04-22 04:47:27 UTC
/dark is a vfat partition mounted with

mount -t vfat /dev/hda1 /dark

exportfs host:/dark

results in

host:/dark: Invalid argument

thus making it impossible to nfs-mount a vfat partition from a Seawolf
machine.

I nfs-mount vfat partitions all the time as this is how I back up the
Windows partitions on my machines (which ordinarily run Linux).  I think
this worked in Fisher and Wolverine, but I can't be entirely sure because
all my wolverine machines are now running seawolf.  I know it worked under
6.2.

Note that exports on my ext2 partitions work fine, so this is not a general
exporting problem.  It is specifically that my vfat partitions can't be
exported.  strace shows nfsservctl returns -1 with errno = EINVAL.  I
haven't dug deeper than that.

Comment 1 Arjan van de Ven 2001-04-22 08:52:03 UTC
NFS exporting of VFAT cannot work, as VFAT doesn't match the requirements
NFS sets on a filesystem. Older 2.2 kernels didn't prohibit this and even
tried to fake some of the required semantics, causing all sorts of problems
when people tried to mount this from non-linux machines.

Comment 2 Arjan van de Ven 2001-04-22 09:12:36 UTC
Alternatives for NFS in this case are using RSYNC or the CODA filesystem:
http://www.coda.cs.cmu.edu/

Comment 3 Jay Berkenbilt 2001-04-23 15:21:13 UTC
These explanations are most helpful.  This explains some of what I saw when I
was looking in the kernel nfs server code.  I guess those checks weren't there
before.

In my case, I'm using home-written backup software.  This just gives me the push
I've needed to add real remote support (a few lines of code the way it's
structured -- I'll just run through ssh).

Thanks for explaining the reasons for this change in behavior, which seems to be
the right thing.

Comment 4 Arjan van de Ven 2001-04-26 11:46:47 UTC
I'll close this as "NOTABUG" then. Feel free to reopen if you object to that.


Note You need to log in before you can comment on or make changes to this bug.