Bug 370391 - 2.6.23.1-21.fc7 fails to boot with "no setup signature found..."
2.6.23.1-21.fc7 fails to boot with "no setup signature found..."
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 16:25 EST by Ben Webb
Modified: 2007-12-07 18:33 EST (History)
0 users

See Also:
Fixed In Version: 2.6.23.8-34.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-07 18:33:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2007-11-07 16:25:38 EST
Description of problem:

After installing the latest kernel update and attempting to reboot (with GRUB)
boot fails with the following error: "no setup signature found...".

Version-Release number of selected component (if applicable):
2.6.23.1-10.fc7 or 2.6.23.1-21.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Install kernel-2.6.23.1-21.fc7.i686.rpm
2. Reboot.
  
Actual results:
Boot fails immediately after the GRUB splash screen with "no setup signature
found..."

Expected results:
Normal booting.

Additional info:
This may actually be a GRUB problem, since it seems that this is a kernel check
to make sure it's loaded correctly by the bootloader. But the problem did not
occur with 2.6.22, and LKML suggests that the boot code was changed in 2.6.23.

This only seems to occur on two of our machines. Both are older i686 machines
with the boot partition on a SCSI disk. SATA and IDE machines have no problems.

As a workaround, a GRUB boot CD will boot each system just fine, even if it
reads vmlinuz and initrd from (hd0) rather than (cd). But obviously requiring a
CD to reboot these machines is a nuisance.
Comment 1 Chuck Ebbert 2007-11-07 16:33:57 EST
How old is the GRUB on those machines?
Comment 2 Ben Webb 2007-11-07 17:26:13 EST
The grub RPM is the latest version: 0.97-13. But I don't know when the last time
'grub-install' was run - probably a long time ago - and don't know how to
determine the version of an 'installed GRUB'. Do you recommend rerunning
grub-install periodically?
Comment 3 Chuck Ebbert 2007-11-07 18:27:26 EST
Try running grub-install and see if that fixes the problem.  The setup code has
been rewritten and there are some boot fixes in 2.6.24 that have not been
backported to Fedora.
Comment 4 Ben Webb 2007-11-07 19:30:24 EST
That seemed to fix it - thanks! It would be a nice enhancement if upgrading the
grub RPM caused it to refresh the stage1, but I can accept that may be tough to
automate safely.
Comment 5 Chuck Ebbert 2007-11-27 18:06:30 EST
Should be fixed in next 2.6.23 kernel update.

Note You need to log in before you can comment on or make changes to this bug.