Bug 370521 - RHEL51:PPORT: Localization issue with French,German and Spanish at firstboot
RHEL51:PPORT: Localization issue with French,German and Spanish at firstboot
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firstboot (Show other bugs)
5.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 17:33 EST by Rezwanul Kabir
Modified: 2008-02-13 08:08 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 18:35:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Call trace on firstboot (431 bytes, text/plain)
2007-11-07 17:33 EST, Rezwanul Kabir
no flags Details

  None (edit)
Description Rezwanul Kabir 2007-11-07 17:33:19 EST
Description of problem:
On RHEL5.1, at firstboot, if the user chooses any of the above mentioned 
languages and press "Forward", a Call Trace ( as attached) appears. If the 
user chooses to continue, when he reaches the "TimeZone" screen and chooses a 
timezone and press "Forward" , he is continually presented with an error 
message saying that "root password must be at least 6 characters in length"

Version-Release number of selected component (if applicable):
firstboot-1.4.27.3-1.el5

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL5.1
2.On firsboot choose any of the above 3 languages
3.
  
Actual results:

Error messages

Expected results:

Should be able to choose any languages.

Additional info:
Comment 1 Rezwanul Kabir 2007-11-07 17:33:19 EST
Created attachment 250971 [details]
Call trace on firstboot
Comment 2 RHEL Product and Program Management 2007-11-07 18:04:42 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Chris Lumens 2008-01-31 18:35:46 EST
I am closing this bug as WONTFIX, as I am proposing removing the language
selection screen entirely due to the fact that it is perpetually broken (as this
and other bugs attest) and that it is entirely misleading in what it
accomplishes.  Please refer to bug 431143 for tracking that resolution.
Comment 4 Larry Troan 2008-02-07 14:01:27 EST
On Thu, 2008-02-07 at 10:22 -0600, Rezwanul_Kabir@Dell.com wrote:
> Hi Larry
> 
> This  bug is being set to WON'T FIX and refers to bug 431143 for 
> explanation. I am writing to inform that it's unacceptable to Dell. 
> Localization at firstboot is very important to us. This is used by
> our users in different regions ( some of them knows/understands little 
> English) to do initial setup. Accepting License Agreement,setting root 
> password,subscribing to RHN all these are offered at firstboot and users
> need to be able to make conscious decisions at this time.
> 
> The developer assigned to this bug wants to eliminate language screen all 
> together at firstboot for the following reasons:
> 
>  1) The code is complex and opaque 
>  2) The installation might not have included other required language
      packages and so applications like Firefox,OpenOffice etc. may not be
      localized. In that case, firstboot language screen offers partial 
      solution.
> 
>  #1 is not our concern 
>  For #2, we are making sure during factory install that all required
>  language packages are installed. So, it doesn't apply to us.
> 
>   As I have discussed during our last weekly call, the resolution to
>   this bug is important to us. I have discussed this with John Hull
>   and have added him to this thread.
> 
>    Thanks.. 
>       --rez
Comment 5 Larry Troan 2008-02-07 14:11:01 EST
Have asked SEG if the current Red Hat position (as listed above) is acceptable
to them long term.
Comment 7 Larry Troan 2008-02-13 08:08:35 EST
Dell believes that Red Hat is in the best position to fix this code.

Per RHEL meeting on 2/12/08, this function is poorly implemented and not easily
fixable. We can assess a different approach in a future update but it will not
be available in 5.2. 

Therefore closing as WONTFIX for 5.2. Ken R. has agreed to explain the rationale
if necessary.


Note You need to log in before you can comment on or make changes to this bug.