Bug 37073 - xxd not localized?
Summary: xxd not localized?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-22 16:38 UTC by Aleksey Nogin
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-22 16:38:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2001-04-22 16:38:09 UTC
It seems that xxd is not using locale to figure out which symbols are
printable and which should be represented by a ".". Because of that, it
substitutes all non-ASCII letters with a ".", which makes it harder to use
xxd for binary editing.

Comment 1 Bernhard Rosenkraenzer 2001-05-21 14:42:42 UTC
You're right, it had hardcoded ASCII values.
I've fixed this in 6.0-0.32.




Note You need to log in before you can comment on or make changes to this bug.