Bug 370771 - kdeedu: ppc, he hates me
kdeedu: ppc, he hates me
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeedu (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F-ExcludeArch-ppc FE-ExcludeArch-ppc64/F-ExcludeArch-ppc64
  Show dependency treegraph
 
Reported: 2007-11-07 22:16 EST by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 23:14:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2007-11-07 22:16:03 EST
ppc builds fail
http://koji.fedoraproject.org/koji/taskinfo?taskID=230111
Comment 1 Rex Dieter 2007-11-07 23:06:23 EST
ppc64 too, ugh
http://koji.fedoraproject.org/koji/taskinfo?taskID=230284
Comment 2 Deji Akingunola 2007-11-07 23:50:19 EST
I think something is wrong with koji and/or qt (or maybe kdelibs). bibletime
fails to build for me, failing on either x86_64 or ppc or ppc64 on 3 different
occasions, while it was successful on others.
http://koji.fedoraproject.org/koji/taskinfo?taskID=230231
http://koji.fedoraproject.org/koji/taskinfo?taskID=230226
http://koji.fedoraproject.org/koji/taskinfo?taskID=230205
Comment 3 Kevin Kofler 2007-11-08 07:26:13 EST
The offending line is this:
class LINKAGE SkipListElement{
It says "invalid function declaration", so apparently it thinks you're trying 
to declare a function called "SkipListElement" which returns a "class LINKAGE". 
This means "LINKAGE" probably isn't defined.
Comment 4 Rex Dieter 2007-11-08 08:06:00 EST
But, but, but, then who/why doesn't this same declaration work on i386, x86_64?

When I find a few spare moments, I'll have to go take much closer look.
Comment 5 Kevin Kofler 2007-11-08 10:46:44 EST
Whatever is supposed to declare LINKAGE probably fails to do so on all arches.
Comment 6 Rex Dieter 2007-11-08 10:51:48 EST
yep, looks that way.
Comment 7 Rex Dieter 2007-11-09 23:14:24 EST
Looks like kdeedu-3.95.2 behaves better,
http://koji.fedoraproject.org/koji/taskinfo?taskID=233973

Note You need to log in before you can comment on or make changes to this bug.