Bug 370791 - sysreport and sos installation conflict when updating a system
sysreport and sos installation conflict when updating a system
Status: CLOSED DUPLICATE of bug 384381
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-07 23:14 EST by carlos
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-28 11:42:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description carlos 2007-11-07 23:14:06 EST
Description of problem:
error when applying updates

Version-Release number of selected component (if applicable):
5.0

How reproducible:
always


Steps to Reproduce:
1.click the update packages icon (top right)
2.click view updates
3.select the 81 updates available
4.click apply updates and continue when asked to add dependencies

  
Actual results:
resolving dependencies for updates 
dependencies added
updating software (in progress)
suddenly... window that says Error updating software.
Then I click details and it shows the information below.


Expected results:
update succesful?


Additional info:
[('file /usr/sbin/sysreport conflicts between attempted installs of
sysreport-1.4.3-13.el5 and sos-1.7-9.1.el5', (6, '/usr/sbin/sysreport', 0L)),
('file /usr/share/sysreport/functions conflicts between attempted installs of
sysreport-1.4.3-13.el5 and sos-1.7-9.1.el5', (6,
'/usr/share/sysreport/functions', 0L))]
Comment 1 Navid Sheikhol-Eslami 2007-11-09 06:46:50 EST
Starting from RHEL5.1, sos has obsoleted sysreport which means that the
sysreport package should be automatically removed and replaced by sos. Please
see the following KBase article:

  http://kbase.redhat.com/faq/FAQ_85_11707

This shouldn't require any user intervention. What versions of sysreport and sos
do you currently have installed ? You can find out by running "rpm -q sos
sysreport".

Removing sysreport manually (rpm -e sysreport) should work-around the dependency
conflict.

Thank you.

-- Navid
Comment 2 carlos 2007-11-09 13:43:26 EST
shell output:
sos-1.7-9.1.el5
package sysreport is not installed

but, if there is not sysreport... how can still be conflict? 

thanks,
Comment 3 Navid Sheikhol-Eslami 2007-11-09 14:08:12 EST
Carlos,

I just tried updating a RHEL5.0 to RHEL5.1 using pup and everything went
smoothly. Looks like you now have the latest version of "sos" installed. Not
sure what caused the conflicts you saw earlier, is the problem still showing now ?

If yes, please attach a sosreport and any the error messages from pup/yum.

Thanks.

-- Navid
Comment 4 Navid Sheikhol-Eslami 2007-11-28 08:27:40 EST
Looks like a bug about pup updating the packages that are obsoleted (BZ#384381).
Re-assigning to component owner.

-- Navid
Comment 5 James Antill 2007-11-28 11:42:56 EST

*** This bug has been marked as a duplicate of 384381 ***

Note You need to log in before you can comment on or make changes to this bug.