Bug 37091 - 2.2.19 errata: iBCS problem due to patch for strlen_user
2.2.19 errata: iBCS problem due to patch for strlen_user
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-22 15:06 EDT by giulioo
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 08:43:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2001-04-22 15:06:23 EDT
In the errata kernel 2.2.19 there is a new patch for iBCS, linux-2.2.19-
ibcs.patch, to work-around the strlen_user problem.

I have an application, that works throught iBCS, that stopped working with 
the 2.2.19 kernel due to this patch.
I get an error about "The TERM variable is not set. Set it and try again", 
even if the TERM variable is defined.

To solve this, I reverted the above mentioned patch and applied the one 
posted here:
http://www.mail-archive.com/linux-kernel@vger.kernel.org/msg38272.html

I'm not a programmer and cannot tell if it does the right thing, what I 
know is that my app is working again now :-)
Comment 1 Arjan van de Ven 2001-04-23 08:43:45 EDT
I'll add this patch to our 2.2.19 tree so that it will be included if/when
we put out a new 2.2.19 kernel.
Comment 2 giulioo 2001-08-10 06:28:58 EDT
This is corrected in latest 2.2.19 errata

Note You need to log in before you can comment on or make changes to this bug.