Bug 370911 - yum-cron sends useless messages if yum-metadata-parser is installed
Summary: yum-cron sends useless messages if yum-metadata-parser is installed
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: yum   
(Show other bugs)
Version: el5
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeff Sheltren
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-11-08 08:39 UTC by Ville Skyttä
Modified: 2007-12-06 14:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 14:12:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2007-11-08 08:39:51 UTC
On CentOS 5, if yum-metadata-parser is installed, settings DOWNLOAD_ONLY=yes, I
get a cron email apparently every time a repository has changed even if there
were no updates available for the system:

/etc/cron.daily/yum.cron:

** Message: sqlite cache needs updating, reading in metadata

$ rpm -q yum-metadata-parser yum yum-cron
yum-metadata-parser-1.0-8.fc6
yum-3.0.5-1.el5.centos.2
yum-cron-0.6-1.el5

rpm -e yum-metadata-parser appears to fix it, but it'd be better if yum-cron
could convince the sqlite cache to shut up.

Comment 1 Habig, Alec 2007-11-08 17:13:26 UTC
yum-cron is already invoking yum with "-e 0 -d 0", which is the minimum possible
verbosity level.

The "Message:" output yum is giving strikes me as an informational level of
message that yum shouldn't be sending to stdout at verbosity level 0.

yum-cron cannot squelch stdout entirely, since we're asking it to output a list
of needed updates.  It also cannot ignore stderr, since we'd like to know when
something fundamental is broken.

So, it looks like this bug is really in yum-metadata-parser - it has an
informational message which is not obeying the overall yum verbosity rules. 
Reassigning the bug to yum, as yum-metadata-parser isn't a bugzilla component of
its own.


Comment 2 Jeff Sheltren 2007-11-09 15:02:17 UTC
Alec, yum in el5 is not maintained in EPEL, it is part of RHEL/CentOS proper.

Ville, if you agree with Alec's assessment, I think re-opening this as a CentOS
bug would be appropriate.

Comment 3 Ville Skyttä 2007-11-10 09:40:57 UTC
Well, the EPEL yum-cron upgrades the CentOS one so chances are that we'll be
seeing a ping pong effect if this is reported there.

Comment 4 Habig, Alec 2007-11-10 13:41:17 UTC
It's not a yum-cron issue, it's a yum one, likely upstream anyway regardless of
the distribution.  Part of yum simply has a debugging statement that's not
listening to the verbosity flags, yum-cron makes us of those flags so notices
the bug.


Comment 5 Ville Skyttä 2007-12-06 14:12:39 UTC
The latest yum-cron for EL5 now comes from CentOS, so I'm moving the issue 
there.  http://bugs.centos.org/view.php?id=2514


Note You need to log in before you can comment on or make changes to this bug.