Bug 37096 - sym53c8xx module
sym53c8xx module
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-22 17:03 EDT by Erik Peters
Modified: 2007-04-18 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-05 20:34:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik Peters 2001-04-22 17:03:45 EDT
When Installing RedHat 7.1:

The install hangs when it says that it is loading the "sym53c8xx" driver.  
By switching to another virtual terminal with a shell prompt, doing 
an "lsmod" shows that status of the module as "initializing".  Another 
virtual terminal which is displaying continuous output about the status of 
the install displays what appears to be a repeating loop of information 
but it passes by too quickly to read.  The part we can pick out is 
the "sym53c8xx.o: " at the start of each line.

The SCSI adaptor is a sym53c895.

When installing RedHat 7.0:
It loaded the ncr53c8xx driver and the installation succeeded.  When not 
using linear mode and intalling LILO into the first sector of the boot 
partition, the system hung on reboot.  When using linear mode and 
installing LILO to the MBR, the reboot succeeded and the system was fully 
functional.
Comment 1 Brent Fox 2001-04-22 23:23:10 EDT
This sounds like a kernel problem, so I'm changing the component.
Comment 2 Francois Isabelle 2001-05-10 13:56:19 EDT
The messages can be read using the "scroll lock" key, this will pause the 
console, you may then use "page-up" or "shift page-up" so scoll up.

I have the same problem here, I think it's because rh7.1 uses sm53c8xx version 
1.6x while 1.7x is being used in mandrae 8 and kernel 2.4.3+ . The specific 
problem might show up due to some bad chip initilization or detection but I 
tried to sync the Rehat 2.4.2-2BOOT kernel tree with sym52c8xx v 1.7.3b from 
the 2.4.3 kernel to rebuild the "boot.img" , but it depends on dynamic dma 
(pci_set_dma ...) which is not available in 2.4.2-2BOOT tree. Any attempt to 
fix it failed for now...

I tried to pass an option to the command line linux sym53c8xx=safe:y without 
success either...

The actual message is regardig the reset:

reseting...
command processing suspended for 2 seconds ( but it does not,  because a 
millisecond after or so the text shows again )
Downloading scsi scripts
ERROR: (c0:0) (8-0-0) (0/7) @ (script 48:f3100004)

then the modules loops over and over...with many attemps to reset targets
Comment 3 Erik Peters 2001-05-10 14:09:14 EDT
Having concluded that RedHat 7.0 works with this controller and 7.1 does not, 
what direction can we expect this to go?  While we have certainly addressed our 
need to get the system up and running, it would be preferred to work with the 
newest version of the kernel and rest comfortably knowing that future releases 
of RedHat will support our Cubix hardware infrastructure.

Please advise as to the likelihood of this problem being resolved and in what 
timeline.  

Thank you.
Comment 4 Arjan van de Ven 2001-05-10 14:18:04 EDT
While we haven't seen the problem with the NCR/Symbios controllers in our
testlab, we are working on an updated kernel for the 7.1 release which has
updated drivers. I cannot comment on the timeline as I don't have any idea
in what timeframe we manage to fix the last few remaining issues with this
update. 

As we so far haven't been able to reproduce the problem, we cannot verify that
we actually fixed it. I know it is hard, but if someone can download the latest
kernelsnapshot from the rawhide directories on the ftp site and test/verify if
it actually fixes this, that would be very appreciated.  

Once these updated drivers are known to work, I will attempt to make a
driverdisk that can be used during the installation for the people who have
problems in that phase.
Comment 5 Francois Isabelle 2001-05-10 14:23:43 EDT
i'll do it right now
Comment 6 Francois Isabelle 2001-05-10 14:28:33 EDT
i'll do it right now, but where is it?
Comment 7 Francois Isabelle 2001-05-10 14:36:30 EDT
Sorry for that silly question, I just found it and if I understand well it's 
based on kernel 2.4.3 my bet is this is going to work... but I have an extra 
question...

Right now I know how ( i think) how to build a redhat install disk ( or at 
least how to update one with custome modules and such.
I can handle the modules.cgz decompression and I can use the loopback block 
device to work on initrd.img but the process is tedious.  Do you have a script 
or command that would take care of building the boot.img file automaticaly from 
the kernel source tree ? Do you have the equivalent for the driver update disk 
format ? I'm sure I miss something here ... and I also miss some time...
Thank you

Francois Isabelle
Comment 8 Arjan van de Ven 2001-05-10 15:06:57 EDT
If the 2.4.3 one works (please test), I will make the 2.4.2 driverdisks 
with this driver... no problem..
Comment 9 Francois Isabelle 2001-05-10 15:32:18 EDT
Well, I'ld like to build an install disk with it, if I had an install disk, I 
could test the driver, and I would end with a working rh-7.1 kernel 2.4.3-xx 
and I would be happy with that.
That's why I asked for instructions on how to build a custom installation disk.
I can't test the kernel-2.4.3BOOT without rebuilding the installation disk from 
it, the scsi adapter can't be removed from the system , so I just can't install 
RH7.1 without this custom disk.  Any quick trick to rebuild an installation 
disk ? ( kernel and modules only )

Thank you
Comment 10 Arjan van de Ven 2001-05-14 10:25:43 EDT
I have made a driverdisk for use during the installation to fix this problem.

The driverdisk is available from:

http://people.redhat.com/arjanv/rhl71/ncrsym/

and the "readme" file should explain how to use this.
Comment 11 James Carrier 2001-05-15 13:22:25 EDT
Hi

I'm having the same problems with my sym53c895 & AMI MegaRAID 500 - RH7 
installed fine, 7.1 just refuses install no matter how I fiddle (claims the 
partiton table is invalid and needs to be intialised a couple of times then 
bombs with 'no valid block devices' error).

Despite much crossing of fingers, I've just tried the new dd with both the i686 
and i386 images and the module fails to load.
Comment 12 Arjan van de Ven 2001-05-15 13:24:39 EDT
For megaraid, you MUST use firmware G158 or later; AMI confirmed a critical bug
in earier versions.
Comment 13 Pieter Langendonck 2001-05-18 13:11:17 EDT
Hello, 

are these disk images okay? I tried it and I'm convinced that I downloaded it
correctly and used
the correct to create a disk. Unfortunately the disk does NOT boot. What can I
have done wrong?

I have Linux on my IBM/Cyrix P200+ which is a i586. I tried it also on my on
Intel P233
with the same problems and I tried it also with another floppydisk and by
downloading it
again. Any suggestions?

Any other people experiencing the same problem??

Pieter
Comment 14 Arjan van de Ven 2001-05-18 13:14:08 EDT
Ehm. It's not a bootable disk, it's a DRIVERDISK, which you can use during the
normal installation. You can make the installer ask for a driverdisk by
specifying "dd" on the commandline:
linux dd
  or
text dd

(I hoped I explained this good enough in the readme)
Comment 15 James Carrier 2001-05-19 07:59:40 EDT
Just to confirm - the dd work perfectly for me, my other install problems were 
100% caused by the MegaRAID firmware (despite nothing obvious in their 
changelogs). Thanks guys (esp. arjanv@redhat.com :) !

Comment 16 Need Real Name 2001-05-21 22:27:52 EDT
All, I have a 53c875 SCSI card, and I still have the same problem installing 
7.1, even after using the new driver disk.  The install freezez when I get 
the "loading 53c8XX module' message, and if I switch to another terminal I get 
the messages similar to those mentioned above: 
reseting...
command processing suspended for 2 seconds 
Downloading scsi scripts
ERROR: (c0:0) (8-0-0) (0/7) @ (script 48:f3100004)

Any thoughts on what else I might try?  7.0 works fine. I don't have any 
special RAID devices, etc.
Comment 17 Arjan van de Ven 2001-05-22 03:55:40 EDT
tlmarti@home.com: can you add an extra "noprobe" to the commandline?
It should then ask you which driver you want; the driverdisk contains 2.
"pick the other one than you are using now" :)
Comment 18 Need Real Name 2001-06-26 14:22:57 EDT
All- Sorry, but I haven't had time to check the last suggestion.  Not sure when 
I'll get back to it, so consider my part of the discussion closed.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.