Bug 371101 - perl update fails with file conflicts in rhel 5
perl update fails with file conflicts in rhel 5
Status: CLOSED DUPLICATE of bug 245989
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl (Show other bugs)
5.1
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robin Norwood
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 07:18 EST by Berthold Cogel
Modified: 2007-11-16 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 09:15:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Berthold Cogel 2007-11-08 07:18:14 EST
Description of problem: perl update fails with file conflicts


Version-Release number of selected component (if applicable):
perl-5.8.8-10/perl-5.8.8-10.el5_0.2

How reproducible:
every time

Steps to Reproduce:
1.update RHEL 5 x86_64 Client
2.
3.
  
Actual results:
yum update
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
rhel-x86_64-client-5      100% |=========================| 1.4 kB    00:00     
rhel-x86_64-client-workst 100% |=========================| 1.4 kB    00:00     
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package perl.x86_64 4:5.8.8-10.el5_0.2 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 perl                    x86_64     4:5.8.8-10.el5_0.2  rhel-x86_64-client-5   12 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error:   file /usr/share/man/man1/c2ph.1.gz from install of
perl-5.8.8-10.el5_0.2 conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/cpan.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/dprofpp.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/enc2xs.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/find2perl.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/h2ph.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/h2xs.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/instmodsh.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/libnetcfg.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/perlbug.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/perlcc.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/perlivp.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/piconv.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pl2pm.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pod2html.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pod2latex.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pod2man.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pod2text.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pod2usage.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/podchecker.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/podselect.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/prove.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/psed.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/pstruct.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/s2p.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/splain.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10
  file /usr/share/man/man1/xsubpp.1.gz from install of perl-5.8.8-10.el5_0.2
conflicts with file from package perl-5.8.8-10


Expected results:
update successful 

Additional info:
Comment 1 Robin Norwood 2007-11-09 09:15:36 EST
Hi,

This looks like the same issue as bug #245989 - RHEL product management is aware
of it, and should have a fix soon.

*** This bug has been marked as a duplicate of 245989 ***

Note You need to log in before you can comment on or make changes to this bug.