Bug 371231 - my PS/2 keyboard does not work with the latest kernel build (but is fine otherwise)
my PS/2 keyboard does not work with the latest kernel build (but is fine othe...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 09:29 EST by Eliran Itzhak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 05:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eliran Itzhak 2007-11-08 09:29:08 EST
Description of problem:
A PS/2 Keyboard stopped working with 2.6.23.1-21.fc7.
It works with 2.6.23.1-10.fc7, and works at the BIOS level too.

Version-Release number of selected component (if applicable):
2.6.23.1-21.fc7

How reproducible:


Steps to Reproduce:
1. Boot to 2.6.23.1-21.fc7 and see if you're ps/2 keybaord works.
2.
3.
  
Actual results:
Keyboard does not work, not even the caps/num lock leds.

Expected results:


Additional info:
The machine is a P3 450Mhz
Comment 1 Chuck Ebbert 2007-11-08 14:08:14 EST
Could you possibly try some of these other kernels to see where the problem
starts? You would need to erase the -21 kernel first, then install each one of
these using rpm and erase after testing:

-17
http://koji.fedoraproject.org/koji/buildinfo?buildID=22895

-19
http://koji.fedoraproject.org/koji/buildinfo?buildID=22976

-20
http://koji.fedoraproject.org/koji/buildinfo?buildID=23094
Comment 2 Chuck Ebbert 2007-11-08 16:17:17 EST
Also, can you boot to runlevel 3 (text mode) and see if the keyboard works
there? This may be an X driver problem of some kind caused by the kernel update.

Just edit /etc/inittab and change the "5" to a "3" in this line:

id:5:initdefault:

Comment 3 Eliran Itzhak 2007-11-09 05:16:59 EST
My system defaults to init level 3 anyway. The keyboard works at the BIOS, but
not after that.
Hmm, the problem seems to have gone away... I've installed cPanel yesterday
(which i already hate) but i doubt if that's what solved the problem.
Anyway, I'm closing this bug report, and will reopen if it comes back later.

Note You need to log in before you can comment on or make changes to this bug.