Bug 371301 - evolution seg faults
evolution seg faults
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 394811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 10:11 EST by Tom Cross
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 14:33:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 495086 None None None Never

  None (edit)
Description Tom Cross 2007-11-08 10:11:39 EST
Fedora 8 with default "desktop" install.  Please let me know if you need any
more debug info.  Thanks


warning: Missing the separate debug info file: /usr/lib/debug/.build-id/43/6d233
16ecf795acef0bb46c636e84ad2ef9ce0.debug
Loading Spamassasin as the default junk plugin
** (evolution:12700): DEBUG: mailto URL command: evolution %s
** (evolution:12700): DEBUG: mailto URL program: evolution
[New Thread -1240859760 (LWP 12724)]
[New Thread -1253049456 (LWP 12725)]
[New Thread -1265632368 (LWP 12726)]
[New Thread -1276122224 (LWP 12727)]
[Thread -1276122224 (LWP 12727) exited]
[Thread -1253049456 (LWP 12725) exited]
[Thread -1265632368 (LWP 12726) exited]
[New Thread -1265632368 (LWP 12728)]
[Thread -1265632368 (LWP 12728) exited]
[New Thread -1265632368 (LWP 12729)]
[Detaching after fork from child process 12730. (Try `set detach-on-fork off'.)]
libnm_glib_nm_state_cb: dbus returned an error.
  (org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkMa
nager was not provided by any .service files
[New Thread -1253049456 (LWP 12731)]
[New Thread -1276122224 (LWP 12732)]
[New Thread -1286612080 (LWP 12733)]
[Thread -1253049456 (LWP 12731) exited]
[New Thread -1253049456 (LWP 12734)]
[Thread -1286612080 (LWP 12733) exited]
[Thread -1253049456 (LWP 12734) exited]
[New Thread -1253049456 (LWP 12735)]
[New Thread -1286612080 (LWP 12736)]
[Thread -1253049456 (LWP 12735) exited]
[Thread -1286612080 (LWP 12736) exited]
[New Thread -1286612080 (LWP 12737)]
[New Thread -1253049456 (LWP 12738)]
[Thread -1286612080 (LWP 12737) exited]

** (evolution:12700): WARNING **: couldn't communicate with gnome keyring daemon
 via dbus: The name org.gnome.keyring was not provided by any .service files

** (evolution:12700): WARNING **: couldn't communicate with gnome keyring daemon
 via dbus: The name org.gnome.keyring was not provided by any .service files
[Thread -1253049456 (LWP 12738) exited]
[New Thread -1253049456 (LWP 12742)]
[New Thread -1286612080 (LWP 12743)]
[New Thread -1297101936 (LWP 12744)]
[New Thread -1307591792 (LWP 12745)]
[New Thread -1318081648 (LWP 12746)]
[Thread -1297101936 (LWP 12744) exited]
[Thread -1307591792 (LWP 12745) exited]
[New Thread -1307591792 (LWP 12747)]
[Thread -1318081648 (LWP 12746) exited]
[Thread -1253049456 (LWP 12742) exited]
[Thread -1286612080 (LWP 12743) exited]
[New Thread -1253049456 (LWP 12748)]
[New Thread -1286612080 (LWP 12749)]
[New Thread -1318081648 (LWP 12750)]
[New Thread -1297101936 (LWP 12751)]
[Thread -1253049456 (LWP 12748) exited]
[Thread -1286612080 (LWP 12749) exited]
[New Thread -1286612080 (LWP 12752)]

** (evolution:12700): WARNING **: couldn't communicate with gnome keyring daemon
 via dbus: The name org.gnome.keyring was not provided by any .service files

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1286612080 (LWP 12752)]
0x06b6f6ed in imap_body_decode (in=0xb34fd1d8, ci=0xb49662f0, 
    folder=0xb4933738, cis=0x9439000) at camel-imap-utils.c:980
980                             if (*inptr++ != ' ')
(gdb) bt
#0  0x06b6f6ed in imap_body_decode (in=0xb34fd1d8, ci=0xb49662f0, 
    folder=0xb4933738, cis=0x9439000) at camel-imap-utils.c:980
#1  0x06b6f1a3 in imap_body_decode (in=0xb34fd208, ci=0xb49663b0, 
    folder=0xb4933738, cis=0x9439000) at camel-imap-utils.c:862
#2  0x06b6f84c in imap_parse_body (body_p=0xb34fd264, folder=0xb4933738, 
    ci=0xb49663b0) at camel-imap-utils.c:1057
#3  0x06b63fb1 in imap_get_message (folder=0xb4933738, uid=0x8ee1230 "3380", 
    ex=0x92e57a4) at camel-imap-folder.c:2125
#4  0x02adde1a in camel_folder_get_message (folder=0xb4933738, 
    uid=0x8ee1230 "3380", ex=0x92e57a4) at camel-folder.c:1074
#5  0x010823c3 in get_message_exec (m=0x92e5790) at mail-ops.c:1700
#6  0x010803a9 in mail_msg_proxy (msg=0x92e5790) at mail-mt.c:500
#7  0x00d83268 in ?? () from /lib/libglib-2.0.so.0
#8  0x00d816df in ?? () from /lib/libglib-2.0.so.0
#9  0x00d0650b in start_thread () from /lib/libpthread.so.0
#10 0x07ca3b2e in clone () from /lib/libc.so.6
(gdb)
Comment 1 Milan Crha 2007-11-08 10:28:03 EST
Thanks for your report. Can you try to print a value of *in (it is a text
variable there), please? I think it contains something strange. Thanks in advance.
Comment 2 Tom Cross 2007-11-08 11:15:47 EST
(gdb) print *in
$1 = 0x9f4d2dd "(\"MESSAGE\" \"RFC822\" (\"name\" \"Fw_ FW_ Celebrity
Estates.eml\") NIL NIL \"7bit\" 3438239 0) \"MIXED\")"

Did I do that right?  I really have no idea what I'm doing in gdb and just
remembered "bt" by pure chance.  Nice... its an email from my father-in-law
thats causing all the trouble.  lol
Comment 3 Milan Crha 2007-11-08 12:43:51 EST
Thanks, this is exactly what I want (the data, I mean) :)
Comment 4 Philip Van Hoof 2007-11-08 14:10:14 EST
Looks like the IMAP server has sent you an invalid ENVELOPE response.

Although you'd be right if you'd say that Evolution should not crash on this.
Comment 5 Milan Crha 2007-11-08 14:33:12 EST
Thanks for your help, moving this upstream and attaching there a patch too. The
fix will be available in next update of evolution-data-server.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=495086
Comment 6 Tom Cross 2007-11-08 14:37:57 EST
Thank you!
Comment 7 Milan Crha 2007-11-22 04:00:21 EST
*** Bug 394811 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.