Bug 371321 - Cannot boot F8
Cannot boot F8
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 10:17 EST by Sammy
Modified: 2008-02-03 18:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 18:59:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2007-11-08 10:17:46 EST
Hi,

One of my machines is not booting with 2.6.23.1-42 or 2.6.23.1-48.fc8 from
Koji.

Right after the grub menu screen, it finds the kernel image file but sais
"Setup not found" and stops.

Tne same F8 system boots with the old 2.6.22.9-91.fc7 kernel.

I have different / abnd /boot partitions. One another system where I have
the same partitions BUT a volgroup defined the system boots fine. Here
is the output of the df command:
# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/sda5             30273116  10749736  17985560  38% /
none                    777316         0    777316   0% /dev/shm
/dev/sda3               101107     15963     79923  17% /boot

It is a SCSI system. On 2.6.22.9 dmesg:

SCSI subsystem initialized
Fusion MPT base driver 3.04.04
Copyright (c) 1999-2007 LSI Logic Corporation
Fusion MPT SPI Host driver 3.04.04
ACPI: PCI Interrupt 0000:02:07.0[A] -> GSI 16 (level, low) -> IRQ 19
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
scsi0 : ioc0: LSI53C1030, FwRev=01011800h, Ports=1, MaxQ=222, IRQ=19
ACPI: PCI Interrupt 0000:02:07.1[B] -> GSI 17 (level, low) -> IRQ 18
mptbase: Initiating ioc1 bringup
ioc1: 53C1030: Capabilities={Initiator}
scsi1 : ioc1: LSI53C1030, FwRev=01011800h, Ports=1, MaxQ=222, IRQ=18

Let me know if more information is needed.
Thanks
Comment 1 Chuck Ebbert 2007-11-08 13:42:39 EST
(In reply to comment #0)
> Hi,
> 
> One of my machines is not booting with 2.6.23.1-42 or 2.6.23.1-48.fc8 from
> Koji.
> 
> Right after the grub menu screen, it finds the kernel image file but sais
> "Setup not found" and stops.
> 

"Setup signature not found"??
Comment 2 Sammy 2007-11-08 15:05:42 EST
Sorry for the delay. Yes, it sais "No setup signature found ..."
What does it mean?
Comment 3 Sammy 2007-11-08 20:45:45 EST
To add some more info: This is a DELL Precision 350, with hyperthreading.
Thanks
Comment 4 Sammy 2007-11-09 11:38:11 EST
I solved the problem by re-running grub:

  $ grub
  grub> root (hd0,2)
  grub> setup (hd0)
  grub> quit

Now it boots fine. I also tried to replace the grub stage files with the new
ones since they dated back to 2003 on this machine but that did not change
anything. I did not do anything to this machine and updated from F7  to F8
via "yum upgrade". So, I presume something has changed somewhere.
Comment 5 Christopher Brown 2008-02-03 18:59:57 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

Closing as issue appears resolved.

Note You need to log in before you can comment on or make changes to this bug.