Bug 371571 - No Internet-connection in F8 kvm installation
No Internet-connection in F8 kvm installation
Status: CLOSED DUPLICATE of bug 240922
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-11-08 13:09 EST by Espen Stefansen
Modified: 2008-05-06 20:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-06 20:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Espen Stefansen 2007-11-08 13:09:28 EST
Description of problem:
On my F8 laptop i installed F8 in kvm, but i can't get connected to Internet. I 
get an IP-adress from the virtual network. If i ping an URL, looks up the 
correct ip-adress but doesn't return anything else.

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Boot up virtual machine
Actual results:
No Internet

Expected results:
Should ba able to connect to Internet

Additional info:
Comment 1 Jan Hutař 2007-11-20 05:15:29 EST
To get Internet working on a guest, I usually need this on a host:

# echo 1 > /proc/sys/net/ipv4/ip_forward
# /sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

(where eth0 is my connection to the Internet)
Comment 2 Peter Gordon 2007-12-21 16:45:39 EST
(In reply to comment #1)
> To get Internet working on a guest, I usually need this on a host:
> # echo 1 > /proc/sys/net/ipv4/ip_forward
> # /sbin/iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

That fixed it nicely for me (using a Win XP SP2 virtual machine). Can we get
this  added to the default initscript or similar?
Comment 3 Peter Gordon 2008-05-06 20:36:22 EDT
This appears to be the same issue as reported in #240922, so I'm closing this as
a duplicate of that one. Please feel free to re-open this bug with further
details should the issue persist differently. Thanks.

*** This bug has been marked as a duplicate of 240922 ***

Note You need to log in before you can comment on or make changes to this bug.