Bug 371631 - doesn't automatically see changes
doesn't automatically see changes
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 13:46 EST by Bill Nottingham
Modified: 2014-03-16 23:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-09 18:20:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-11-08 13:46:24 EST
Description of problem:

When editing the XML machine description by hand to remove a device, I can't
actually restart the domain without restarting libvirtd; it doesn't see the
changes otherwise.

Version-Release number of selected component (if applicable):

virt-manager-0.5.2-2.fc8
libvirt-0.3.3-2.fc8
Comment 1 Daniel Berrange 2007-11-08 13:53:12 EST
You can send it a SIGHUP (or /etc/init.d/libvirtd reload).

Guess we could hook up to inotify though to watch for changes.
Comment 2 Bug Zapper 2008-05-13 23:52:05 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Cole Robinson 2009-05-09 18:20:50 EDT
This bug is pretty old, and since it was filed we have tried to steer people away from editing XML files directly in /etc/libvirt/*, instead using 'virsh edit'.

Closing as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.