Bug 3717 - custom kernel rebuild make xconfig error
custom kernel rebuild make xconfig error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-24 18:09 EDT by papa
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 03:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description papa 1999-06-24 18:09:50 EDT
While building a custom kernel using 2.2.5-22 i used the
following steps.
make mrproper
make xconfig
In xconfig i noticed that when i save the configuration
with either the <store configuration> or <save and exit>
buttons i received the following message in the xterm
window.

ERROR - Attempting to write value for unconfigured variable
(CONFIG_FB_ATY)

After experimentation found that this error can be
replicated by doing only the following
make mrproper
make xconfig
<console drivers>    'do not change anything!
<main menu>
<store configuration> or <save and exit>

Do not know if this is related, but have been unable to gen
a custom kernel with 2.2.5-22 if anything is changed with
xconfig. All attempts so far result in hang on reboot at
module dependencies, or depmod -a 2.2.5-22 with unresolved
dependencies. And yes, before you ask, i
deleted /lib/modules/2.2.5-22 before i did make
modules_install.
Comment 1 Cristian Gafton 1999-07-28 03:08:59 EDT
I would recommend "make menuconfig" instead. "make xconfig is hardly
maintained these days...
Comment 2 papa 1999-08-16 18:05:59 EDT
"make xconfig is hardly maintained these days...

If this is true remove xconfig from the distribution, as it is the
one most people will attempt to use due to the gui interface. Leaving
a guaranteed failure in an important aspect to your product is
ensuring the failure of the adoption of that product.
Comment 3 Bill Nottingham 1999-08-31 18:13:59 EDT
To get rid of the hang on depmod, upgrade to the latest
initscripts from Raw Hide - there's a very silly bug in it.

Note You need to log in before you can comment on or make changes to this bug.