Bug 371701 - mount.cifs not handling native format unc strings correctly with subshares
mount.cifs not handling native format unc strings correctly with subshares
Status: CLOSED DUPLICATE of bug 370501
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 14:22 EST by Jeff Layton
Modified: 2007-11-16 20:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 16:18:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Layton 2007-11-08 14:22:54 EST
I have a [public] share set up on a samba server. That share has a 'p1'
directory in it. I can mount this directory using the following format:

//server/public/p1

...but not with:

\\server\public\p1

The difference is in how mount.cifs is parsing the string. When using forward
slashes as a delimiter, the options string looks like this:

unc=//server\\public,ip=www.xxx.yyy.zzz,user=root,ver=1,rw,noauto,guest,sec=none,prefixpath=p1

...with backslashes I get an option string like this:

unc=//server\\public\\p1,ip=www.xxx.yyy.zzz,user=root,ver=1,rw,noauto,guest,sec=none

...mount.cifs is not correctly stripping the "p1" off of the unc string and
adding the prefixpath option with native format UNC strings.
Comment 1 Jeff Layton 2007-11-08 16:18:00 EST
actually...now that I look, this bug and bug 370501 are pretty closely related.
I'll close this as a dupe, since I think we can fix both in userspace...


*** This bug has been marked as a duplicate of 370501 ***

Note You need to log in before you can comment on or make changes to this bug.