Bug 371791 - RHEL 5.1 x64 xen does not work with 256GB memory
RHEL 5.1 x64 xen does not work with 256GB memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
low Severity high
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 15:33 EST by Jeff Svatek
Modified: 2010-10-22 16:09 EDT (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:01:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Serial Output Using dzickus kernel (65.64 KB, application/octet-stream)
2008-03-17 17:22 EDT, Jeff Svatek
no flags Details
SOS report of DL580G5 with 256GB (1.62 MB, application/octet-stream)
2008-03-17 17:24 EDT, Jeff Svatek
no flags Details

  None (edit)
Description Jeff Svatek 2007-11-08 15:33:13 EST
Description of problem:
RHEL 5.1 x64 xen should support 256GB of memory installed.
cat /proc/meminfo only shows 163GB with this configuration
When running certification with greater than 64GB, the system will lock up.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 5 Update 1 x64 (10/17/2007)
Xen Kernel

How reproducible:
Always, use the Xen kernel and more than 64GB.  We are testing using an HP 
ProLiant DL580 G5 with 256GB of memory.  HTS was run on the BL680c with more 
than 64GB (128GB) which encountered the lockup.
Comment 1 Sandy Garza 2007-11-29 10:53:42 EST
Issue tracker opened for this. 140420
Comment 2 Ronald Pacheco 2008-02-07 11:56:01 EST
This has been committed for the beta.

in 2.6.18-71.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 3 Ronald Pacheco 2008-02-07 12:06:34 EST
Red Hat is tracking the patch for this issue under the following BZ, which is
confidential to another party.

227614.

Please make sure you scan the changelog for the beta for this reference BZ.
Comment 4 Ronald Pacheco 2008-03-13 16:45:47 EDT
Looks like information is not properly flowing from IT to BZ.  Here's the latest
entry in the IT:

     Event posted 03-12-2008 01:54pm EDT by sandy.garza
Internal Status set to 'Waiting on Support' 	
Retest failed with Kernel 82.el5.  


Status set to: Waiting on Tech 
Comment 5 Chris Lalancette 2008-03-13 16:53:48 EDT
Um, we need a lot more information than that.  How does it fail?  Any console
logs, anything from dmesg, xm dmesg, etc. etc.?

Chris Lalancette
Comment 6 Jeff Svatek 2008-03-17 17:22:50 EDT
Created attachment 298310 [details]
Serial Output Using dzickus kernel

This is from the xen -75 kernel on dzickus.  This is the output when the kernel
boots to xen via the serial port.  I ran with the beta release of the kernel
-85 with similar results.
Comment 7 Jeff Svatek 2008-03-17 17:24:10 EDT
Created attachment 298311 [details]
SOS report of DL580G5 with 256GB

This is using RHEL 5.1 x64 base media only.
Comment 8 Issue Tracker 2008-03-20 15:59:32 EDT
Sandy/Jeff, 

Can you please describe exactly what you're seeing with the new kernel? I
believe we're seeing something different. Under -53.el5, we saw the
following in 'xm dmesg': 

(XEN) WARNING: Only the first 166 GB of the physical memory map can be
accessed
(XEN)          by compatibility mode guests. Truncating the memory map...
...
(XEN) System RAM: 169212MB (173274008kB)

However with -75.el5, we don't see the warning, and it looks like the
system has far less memory in it. 

Can you attach a sosreport from the system running -75.el5 (or better yet,
Beta Snapshot 1)? 

Thanks! 

-David

Internal Status set to 'Waiting on Customer'
Status set to: Waiting on Client

This event sent from IssueTracker by dwa 
 issue 140420
Comment 9 Jeff Svatek 2008-03-26 17:30:00 EDT
When I run using Snapshot 1 the system will get mostly through the boot 
process...

(XEN) Xen is relinquishing VGA console

I then lose output to my monitor (above is the last thing displayed on the 
screen).  The serial output I provided is once the system gets to this point, I 
then log in via a serial cable.  The system is in the hypervisor kernel.  Am I 
stuck here or is there a way to get to bash?
Comment 10 Jeff Svatek 2008-04-09 16:08:47 EDT
The system shows 256GB using the RHEL 5.2 Snapshot 3. Alt sysrq M shows all 
memory.  /proc/meminfo shows all memory.  HTS memory test passes as well.
Comment 13 Bill Burns 2008-04-30 11:30:31 EDT
 fixed in kernel-2.6.18-87.el5 (Snapshot 3)
Comment 16 errata-xmlrpc 2008-05-21 11:01:12 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.