Bug 371821 - boot command line "ip=xx.xx.xx.xx" ignored, still defaults to DHCP
boot command line "ip=xx.xx.xx.xx" ignored, still defaults to DHCP
Status: CLOSED DUPLICATE of bug 374271
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 15:56 EST by george.b.milner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-25 20:13:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
syslog messages from DHCP server (5.31 KB, text/plain)
2007-11-25 18:59 EST, Boleslaw Ciesielski
no flags Details

  None (edit)
Description george.b.milner 2007-11-08 15:56:50 EST
Description of problem: anaconda ignores static IP information on the command line.


Version-Release number of selected component (if applicable): anaconda installer
11.3.0.50


How reproducible: Always ( only tried on D830 and D600 laptops so far )


Steps to Reproduce:

1. boot from usb device with diskboot.img on it
2. "vmlinuz initrd=initrd.img text ks=http://192.168.0.1/ks.cfg ksdevice=link
ip=192.168.0.2 netmask=255.255.255.0 noipv6
3.
  
Actual results:
"Sending request for IP information for eth0...", I waited 10 minutes and
anaconda did not revert back to the "interactive" screen.

Log screen shows eth0 link is up.


Expected results: A kickstart install.


Additional info:
I tried with/without ksdevice=[link|eth0|eth1]
Works in FC6 and FC7
Comment 1 Boleslaw Ciesielski 2007-11-25 18:58:32 EST
I am seeing the same problem but only with x86_64. The i386 version works fine.

In addition, the kickstart fails as described above even if I have working DHCP
server and use it for installation. Attached is a portion of the syslog from the
machine that's running the DHCP server. The first DHCPDISCOVER is from the PXE
boot and it works fine. The second and subsequent DHCPDISCOVER (after the tftp
messages) are from anaconda. It seems to be stuck in a DHCPDISCOVER loop and
never issues DHCPREQUEST, even though the server is replying with DHCPOFFER.
Comment 2 Boleslaw Ciesielski 2007-11-25 18:59:33 EST
Created attachment 268431 [details]
syslog messages from DHCP server
Comment 3 Alexandre Oliva 2007-11-25 20:13:42 EST

*** This bug has been marked as a duplicate of 374271 ***

Note You need to log in before you can comment on or make changes to this bug.