Bug 37191 - logged out after entering TERM=scoansi....
Summary: logged out after entering TERM=scoansi....
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncurses   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-23 11:14 UTC by maikcat
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-20 12:04:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description maikcat 2001-04-23 11:14:08 UTC
when i enter TERM=scoansi im logged out!?! (logged on as root)
my system:
asus a7v
amd thunderbird 1000Mhz
256mb ram
Rh linux 7.1

also tested on ibm gl300 same result....

Comment 1 Bernhard Rosenkraenzer 2001-05-03 15:07:46 UTC
Verified... Ncurses falls over FZ\E[^ for some reason. debugging.


Comment 2 Bob Rasmussen 2001-06-15 22:20:26 UTC
It would appear that the caret needs a backslash in front of it, because caret 
ordinarily means control-something, based on the next character, such as "^a" 
for control-A. But nothing follows it.

So an immediate fix would be to patch the termcap file to "FZ=\E[\^".

A further fix would be to fix the ncurses routine so it wouldn't blow up on 
this situation.

Comment 3 Bernhard Rosenkraenzer 2001-07-20 12:04:24 UTC
Workaround added in termcap-11.0.1-10


Note You need to log in before you can comment on or make changes to this bug.