Bug 37193 - Previous balances go bad when entering new xaction.
Previous balances go bad when entering new xaction.
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: gnucash (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 09:10 EDT by Kirk Morrow
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-24 13:41:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GnuCash file showing error (6.24 KB, application/octet-stream)
2001-04-23 14:28 EDT, Kirk Morrow
no flags Details
GnuCash screenshot of bug 37193 (33.90 KB, image/gif)
2001-04-24 13:15 EDT, Kirk Morrow
no flags Details

  None (edit)
Description Kirk Morrow 2001-04-23 09:10:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)


When entering a new transaction into a register, the balance on the last
few transactions will change to incorrect values.  It seems to occurs
mostly with transactions where funds are transfered from one account to
another.  In this case, all transactions since the last transfer from the
same other account are affected, regardless if the date of the new
transaction is later than the transactions in between.

Reproducible: Always
Steps to Reproduce:
1. In the register for account "X" record a transaction of funds from
account "Y" and use a unique "Description" for the transaction.

2. Enter a several transactions with dates after the transaction above.

3. Start entering with the same description as that used in Step 1, but
with a date later than all those above.

4. As you tab out of the description field and GnuCash remembers the
previous transaction values from step 1, watch the above balances change. 
	

Actual Results:  The final balances on previous transactions change to
incorrect values.

Expected Results:  The balances should not have been affected and stayed
correct.
Comment 1 Tim Powers 2001-04-23 09:33:12 EDT
I can't reproduce the problem. I created two separte accounts, checking and
savings. Tranferred money between the two, did some random transactions, then
used the same description as in step 1 to transfer to the other account. I can't
reproduce this.

Tim
Comment 2 Kirk Morrow 2001-04-23 14:28:48 EDT
Created attachment 16125 [details]
GnuCash file showing error
Comment 3 Kirk Morrow 2001-04-23 14:31:15 EDT
1. Open the file attached above with GnuCash
2. Open the Mortgage Y register
3. Enter "HomeSide Lending" in the Description field.
4. Watch the balance when you Tab to the next field.
Comment 4 Tim Powers 2001-04-23 15:07:21 EDT
This is weird, it *only* happens if you use tab to change feilds (using the
mouse doesn't show the problem).

Can you please report this to the gnucash folks and refer them to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=37193

I will contact them as well.

Until there's a fix, use the mouse as a workaround :/

Tim
Comment 5 Kirk Morrow 2001-04-24 13:15:48 EDT
Created attachment 16246 [details]
GnuCash screenshot of bug 37193
Comment 6 Tim Powers 2001-04-24 13:41:54 EDT
I just got mail from one if the authors, I am CC'ing my response back to you. In
short (for the purposes of bugzilla), it seems it is confusing, although
expected behaviour.

Tim
Comment 7 Kirk Morrow 2001-04-24 22:58:58 EDT
If entering a transaction with a date previous to other transactions, it will
update the register as you tab between fields.  So if transactions are entered
with a future date and then a current dated transaction is enter, it will alter
the values.  I'm going to go ahead and close this as a bug.  I'll though I don't
like this behavior, it's not really a bug.  The values are mathematically
correct after all.

Note You need to log in before you can comment on or make changes to this bug.