Bug 37196 - Where is kernelcfg?
Where is kernelcfg?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernelcfg (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 09:46 EDT by Daniel Tourde
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 09:46:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Tourde 2001-04-23 09:46:28 EDT
Hi!

I have just installed RedHat 7.1 on a 2.5 years old Dell machine (Dell 
Dimension XPS R400) equipped with a Winmodem and an Altec USB sound 
system).

Kernel 2.2.x did not recognize either my internal winmodem or my 
soundcard. I was hoping that 2.4.x would.
When I boot the machine, The winmodem (at least the name) is seen and 
recognized.
However, when I want to configure it, the automatic RedHat procedure do 
not find or see my winmodem. My sound system is not recognized either.

I decided to try kernelcfg and then I discovered that it was not installed 
and it was not in any of the 3 CDs.


Then comes the very simple question: Where is the kernelcfg rpm?
And beside, will my winmodem and my sound card + USB loudspeakers work?


Thanks in advance for any answer.


Daniel
Comment 1 Phil Knirsch 2001-04-23 10:12:10 EDT
Quite a few questions in one single bugzilla entry, but better than splitting
them up :)

Anyway, here the answers:

Kernelcfg has been removed from the distribution for lack of use and has
partially been replaced by kudzu (the automatic hardware detection app) (we are
also always very tight on space on the CDs, so even though this was a very small
app in still consumed unecessary hd space).

You can still use the 7.0 kernelcfg program or i can send you the newest and
greates version (although it hardly changed, so no real need here).

As to your various hardware parts:
Winmodems have always been a problem under Linux due to the proprietary drivers
of the vendors (which we don't ship with RedHat, we are, after all, a Open
Source company and stick to it as far as possible).

The sound card might work, quite a few are supported, but without specific
details i can't really answer this question ;).

USB loudspeakers might still be a little problematic, depending on how well the
speaker identifies itself. There is basically usb speaker support in Linux and
our 2.4 kernel and hotplug should be able to find and configure it.

Hope this answers most (if not all) of your questions.
Comment 2 Daniel Tourde 2001-04-23 11:38:58 EDT
Hi!

OK, I see. About kernelcfg, maybe it should be left on the powertools CD. As a 
matter of fact, there is still an icon for it under KDE2 and this is slightly 
confusing. It was there under 7.0 and disappeared under 7.1 and I was wondering 
why. I would be interested to know where the last version is. It might help me 
anyway.... (even if I love kudzu for its simplicity (it works by itself...))

My winmodem is a :
US Robotic. 56K Voice Win from 1998 connected (according to windows98) on Com2. 
I know winmodems are shit but I did not choose... :(

The louspeakers are:
Altec Lansing Multimedia USB Speakers ACS 495.

The sound card is:
TBS Montego. It seems that it does a basic Sound Blaster Emulation, it is a PCI 
card, as far as I understand what Windows 98 says... 


I would be very glad to get these devices working under Linux... The machine 
has been bought in Augusti 98... :(
Comment 3 Phil Knirsch 2001-04-24 13:04:27 EDT
OK, just checked a couple of HOWTO's and other pages, here the basic info:

USR Winmodem: There doesn't seem to exist a Linux driver for it at all, at least
not from what i could find. Also, the USR Winmodem came in 20-30 different
releases and revisions... There are not drivers available from 3com (which
bought USR some time ago), so you might be OOL here.

The ACS 495 USB speakers are on the list of not working speakers on the
www.linux-usb.org page, although some other models of Altec are supposed to
work. You might want to get in contact with the guy developing the drivers, just
hop to the linux-usb site and ask him.

Last but not least he TBS Montego card seems to have suffered the same problem
as Turtle Beach didn't want to release specs. OSS seesm to have a Beta driver,
but you have to buy them (no free software here). Officially (according to the
Hardware HOWTO) it is not supported, so probably no ALSA (free) driver here
either.

Sorry for all that rather dissapointing information, but tell the companies
involved to do something about it, don't blame it on Linux...

Read ya, Phil
Comment 4 Daniel Tourde 2001-04-24 14:33:40 EDT
OK. Bad luck for me....
Thanks for having checked.


Daniel

Note You need to log in before you can comment on or make changes to this bug.