This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 37197 - Cannot rebuild Gnat from the .src.rpm
Cannot rebuild Gnat from the .src.rpm
Status: CLOSED NOTABUG
Product: Red Hat Powertools
Classification: Retired
Component: gnat (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 09:49 EDT by Daniel Tourde
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-23 09:49:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Tourde 2001-04-23 09:49:46 EDT
Hi!

I wanted to install Gnat on my new RedHat 7.1 machine. I picked up the 
.i386.rpm and saw that it depends on gcc 2.81 instead of 2.96. I decided 
to rebuild the package by myself (rpm --rebuild) and it does not work. 
Gnat needs itself to build itself.

So, 2 questions:
Why Gnat is not using gcc 2.96?
Why cannot it be rebuild with rpm --rebuild.



Thanks in advance for any answer


Daniel
Comment 1 Ngo Than 2001-04-23 10:30:54 EDT
1) it only works with gcc-2.81

2) You must install the binary package for GNU Ada before you can rebuild
this package from the sources.
 
This is required, because this package provides an gcc based GNU Ada95
compiler (GNAT) and it's frontend is written in Ada95 itself. So you
need a bootstrap compiler (like you need a C compiler to build gcc).
 
The preparation of the package build will fail now, if GNU Ada isn't
installed.
Comment 2 Daniel Tourde 2001-04-23 11:27:58 EDT
OK, I understand.

Thanks for your answer

Daniel

Note You need to log in before you can comment on or make changes to this bug.