Bug 371991 - Kernel 2.6.23.1-21.fc7 causes error message to be displayed when attempting to upload images from a usb digital camera as non-root user.
Kernel 2.6.23.1-21.fc7 causes error message to be displayed when attempting t...
Status: CLOSED DUPLICATE of bug 362221
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 20:17 EST by Tom
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-27 18:05:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom 2007-11-08 20:17:47 EST
Description of problem:
Kernel 2.6.23.1-21.fc7 causes error message "An error occurred in the io-library
('Could not claim the USB device')" to be displayed when attempting to upload
images from a usb digital camera as non-root user.

Version-Release number of selected component (if applicable):
2.6.23.1-21.fc7 (possibly all 2.6.23.xxx kernels)

How reproducible:
Apparently always, 2.6.22.9-91 & 2.6.21-1.3194 work fine.  

Steps to Reproduce:
1.  Upgrade to 2.6.23.1-21.fc7 kernel
2.  Attempt to access usb digital camera as non-root user
3.
  
Actual results:
Error message displayed, no non-root access to camera

Expected results:
Images should be accessible

Additional info:
Apparently hacking udev rules can allow access, but this dosen't seem wise.
Comment 1 Chuck Ebbert 2007-11-27 18:05:36 EST

*** This bug has been marked as a duplicate of 362221 ***

Note You need to log in before you can comment on or make changes to this bug.