Bug 372031 - Updatedb crashes
Updatedb crashes
Status: CLOSED DUPLICATE of bug 242715
Product: Fedora
Classification: Fedora
Component: mlocate (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Miloslav Trmač
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-08 20:56 EST by Joshua Rosen
Modified: 2008-02-13 09:22 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 09:22:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2007-11-08 20:56:11 EST
Description of problem:
Updatedb crashed with the following message,

updatedb: src/updatedb.c:730: scan_cwd: Assertion `name_size > 1' failed.
Abort

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dag Arne Eriksson 2008-02-12 19:30:10 EST
Version-Release number of selected component (if applicable):
Fedora 8
updatedb (mlocate) 0.18

How reproducible:
Not tested, probably 100%

Steps to Reproduce:
1. run updatedb on a newly installed Fedora 8 install.
  
Actual results:
Updatedb crashes with the following message,
updatedb: src/updatedb.c:730: scan_cwd: Assertion `name_size > 1' failed.
Abort

Expected results:
updatedb runs successfully,

Additional info:
Confirmed on newly installed Fedore 8 system today. (no updates were done).

Fix: add "/sys/module/nousb" to PRUNEPATH in /etc/updatedb.conf
Comment 2 Andreas Thienemann 2008-02-12 19:51:20 EST
No idea why this was assigned as bacula. Reassigned to mlocate.
Comment 3 Miloslav Trmač 2008-02-13 09:22:23 EST
Thanks for your report.  This bug is already tracked as #242715.

> Fix: add "/sys/module/nousb" to PRUNEPATH in /etc/updatedb.conf
That doesn't really fix the underlying bug.  A better workaround is to run
(/etc/cron.daily/mlocate.cron) instead of updatedb.

*** This bug has been marked as a duplicate of 242715 ***

Note You need to log in before you can comment on or make changes to this bug.