Bug 372101 - network stop before netfs service
network stop before netfs service
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 405401
  Show dependency treegraph
 
Reported: 2007-11-08 22:07 EST by Igor A Tarasov
Modified: 2008-09-29 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-29 22:44:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor A Tarasov 2007-11-08 22:07:36 EST
Shutdown process take very long time when using NetworkManager to connect to 
network (I use WIFI) and network filesystem is active.

In shutdown process NetworkManager service stop first and wifi adapters 
disconfigured. Then netfs service try to umount active connections to network 
shares (CIFS for example) and can't do it very long time (CIFS response 
timeout), because network manager is already stopped and wi-fi network 
adapters disassociate.

Workaround is that NetworkManager must start before netfs and stop after 
netfs.
Comment 1 Dan Williams 2008-09-29 22:44:44 EDT
F9 and later fix this; unfortunately it's not possible to redo all the init priorities on F8.

Note You need to log in before you can comment on or make changes to this bug.