Bug 37214 - Can't use both PCMCIA slots after upgrade - IRQ in use
Can't use both PCMCIA slots after upgrade - IRQ in use
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel-pcmcia-cs (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-23 11:08 EDT by wilburn
Modified: 2015-01-04 17:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-25 21:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wilburn 2001-04-23 11:08:43 EDT
I upgraded an NEC Versa LX from 7.0 to 7.1

It has 2 PCMCIA cards, an UltraSpeed C56 K RX (generic serial) modem and a
3COM 3C589D-TP network card

Worked fine with 7.0, but now only one card at a time will work. Both try
to get the same IRQ - IRQ11

Installing one card works, putting in the second gives in /var/log/messages

Apr 23 09:04:56 wilburn2 cardmgr[576]: initializing socket 0
Apr 23 09:04:56 wilburn2 cardmgr[576]: socket 0: Serial or Modem
Apr 23 09:04:56 wilburn2 cardmgr[576]: executing: 'modprobe serial_cs'
Apr 23 09:04:56 wilburn2 cardmgr[576]: executing: './serial start ttyS0'
Apr 23 09:04:56 wilburn2 kernel: serial_cs: RequestIRQ: Resource in use
Apr 23 09:04:56 wilburn2 kernel: ttyS00 at port 0x03f8 (irq = 0) is a 16550A

Here is /proc/interrupts (NIC installed first)

          CPU0
  0:    7499806          XT-PIC  timer
  1:        540          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          7          XT-PIC  Ricoh Co Ltd RL5c478 (#2)
  8:          1          XT-PIC  rtc
  9:          0          XT-PIC  usb-uhci
 10:        674          XT-PIC  Ricoh Co Ltd RL5c478
 11:    2272017          XT-PIC  3c589_cs
 12:        135          XT-PIC  PS/2 Mouse
 14:      16605          XT-PIC  ide0
 15:          0          XT-PIC  ide1
NMI:          0
ERR:          5

Anyone want more info before I try a clean install?
Comment 1 Brent Fox 2001-04-23 11:33:37 EDT
This sounds like a kernel problem.  Changing component.
Comment 2 John McDonald 2001-06-24 11:26:03 EDT
I'm having a similar problem with my 7.1 installation.  I can use a single PCMCIA card with no problems, but when I try to boot with a second card (or 
stop and restart cardmgr), I get a "RequestIRQ: Resource in use" error for the second card.  I'm running on an NEC Versa 6030X machine.  I've tried 
adjusting available IRQs in /etc/pcmcia/config.opts... blocked 9 & 10 as listed in the Release Notes... but I still get the error.  (Question: looks like yenta 
is trying to use IRQ9, but the RedHat 7.1 release notes say to exclude 9 & 10 for these NEC Versa machines.  How do I tell yenta to exclude 9 & 10?  It 
doesn't look at pcmcia/config.opts.)

I've also turned off my internal modem (COM2) in the bios settings to free up IRQ3, and added an include for IRQ3 in my pcmcia/config.opts file... still no 
luck. 

If it helps in figuring out what's wrong, attached is the relevant output from dmesg and my /proc/interrupts contents...

------------------------------------- excerpt from dmesg ------------------------------------------
Linux PCMCIA Card Services 3.1.22
  options:  [pci] [cardbus] [pm]
PCI: Found IRQ 5 for device 00:03.0
PCI: Found IRQ 9 for device 00:03.1
Yenta IRQ list 0880, PCI irq5
Socket status: 30000010
Yenta IRQ list 0880, PCI irq9
Socket status: 30000010
cs: IO port probe 0x0c00-0x0cff: excluding 0xc00-0xc17
cs: IO port probe 0x0100-0x04ff: excluding 0x200-0x207 0x220-0x22f 0x330-0x337 0x378-0x37f 0x388-0x38f 0x398-0x39f 0x4d0-0x4d7
cs: IO port probe 0x0a00-0x0aff: clean.
cs: memory probe 0xa0000000-0xa0ffffff: clean.
wvlan_cs: WaveLAN/IEEE PCMCIA driver v1.0.6
wvlan_cs: (c) Andreas Neuhaus <andy@fasta.fh-dortmund.de>
wvlan_cs: index 0x01: Vcc 5.0, irq 11, io 0x0100-0x013f
wvlan_cs: Registered netdevice eth0
wvlan_cs: MAC address on eth0 is 00 60 1d 23 20 83
NET4: Linux IPX 0.46 for NET4.0
IPX Portions Copyright (c) 1995 Caldera, Inc.
IPX Portions Copyright (c) 2000, 2001 Conectiva, Inc.
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
NET4: AppleTalk 0.18a for Linux NET4.0
xirc2ps_cs: RequestIRQ: Resource in use
wvlan_cs: MAC address on eth0 is 00 60 1d 23 20 83
wvlan_cs: Valid channels: 1 2 3 4 5 6 7 8 9 10 11
xirc2ps_cs.c 1.31 1998/12/09 19:32:55 (dd9jn+kvh)
xirc2ps_cs: RequestIRQ: Resource in use

--------------------------------- contents of /proc/interrupts after cardmgr started  ---------------------------------------
           CPU0
  0:     352040          XT-PIC  timer
  1:        519          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:          0          XT-PIC  Texas Instruments PCI1130
  8:          1          XT-PIC  rtc
  9:          5          XT-PIC  Texas Instruments PCI1130 (#2)
 11:      35060          XT-PIC  wvlan_cs
 12:        476          XT-PIC  PS/2 Mouse
 14:     293549          XT-PIC  ide0
NMI:          0
ERR:          0
Comment 3 Arjan van de Ven 2001-06-25 02:50:19 EDT
Quick question: does your networkcard have a modem as well ?
Comment 4 John McDonald 2001-06-25 11:53:25 EDT
No, no modem.  But it is a combo card... has both 10base2 and 10baseT capability, with an option to add 100baseT.  The VERSA Laptop has an 
integrated modem, but I shut that off in the BIOS to free up the IRQ. 

If you've got time to field a question, I am curious about something.  I'm experienced with software and other O/Ss, but am somewhat new to Linux 
admin.  It appears, from the little bit of digging that I've done, that there's something called yenta that's built into the kernel that manages (i.e. sets up 
the IRQs, etc. for) the PCMCIA slots, and then the cardmgr sets up the configurations for whatever cards you plug in.  It seems the cardmgr uses the 
/etc/pcmcia/config, /etc/pcmcia/config.opts, ... files to control its configuration, but yenta doesn't use these same files.

It *appears* that yenta is trying to grab IRQs 5 & 9 for the two slots, and that whichever card I insert first (wavelan card in the case of the output above) 
gets IRQ 11... then I get the "Resource in use" message for the next card.  At first, I thought it was talking about the IRQ it was trying to assign to that 
second card, but the more I think about it, the more I think that the conflict is with the second IRQ that yenta is grabbing... in this case, IRQ 9.  I know in 
one of the redhat readme's, it says that for NEC VERSA 6000 series machines, you need to specifically exclude IRQs 9 and 10 from use by pcmcia... it 
says to put exclude statements into the /etc/pcmcia/config.opts file (which I've done).  But how do I do the same exclusion for yenta?  Does yenta have 
an equivalent opts file?
Comment 5 Arjan van de Ven 2001-06-25 11:57:45 EDT
Yenta doesn't have a config file, and in theory it doesn't need one as
it uses exactly what the bios tells it to use.

I asked the question about the modem as it appears the xirc2ps driver
is only willing to share irqs when it also has a modem built in; now you've
confirmed my suspicion I'll investigate this further.
Comment 6 Dave Jones 2004-10-25 21:53:55 EDT
hopefully fixed in current releases, please reopen if reproducable with
Fedora/RHEL.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.